Difference between revisions of "Combo view"

From FreeCAD Documentation
Jump to navigation Jump to search
(Remove excessive spacing)
(Don't use a section for the background)
Line 10: Line 10:
 
* [[#Lower section|Lower section]] shows the [[property editor|Property editor]]. It contains two tabs: the {{MenuCommand|View}} and {{MenuCommand|Data}} properties. The [[property_editor|Property editor]] is only shown when the {{MenuCommand|Model}} tab is '''active''', that is, when the [[tree view|tree view]] is visible.
 
* [[#Lower section|Lower section]] shows the [[property editor|Property editor]]. It contains two tabs: the {{MenuCommand|View}} and {{MenuCommand|Data}} properties. The [[property_editor|Property editor]] is only shown when the {{MenuCommand|Model}} tab is '''active''', that is, when the [[tree view|tree view]] is visible.
  
==Background== <!--T:8-->
+
<!--T:8-->
 
+
{{Emphasis|Note:}} originally the upper part ([[tree view|tree view]]) was separate from the lower part ([[property editor|property editor]]) but then they were combined, and thus the "combo" view was created.
Originally the upper part ([[tree view|tree view]]) was separate from the lower part ([[property editor|property editor]]) but then they were combined, and thus the "combo" view was created.
 
  
 
== Upper section == <!--T:9-->
 
== Upper section == <!--T:9-->
Line 34: Line 33:
  
 
<!--T:11-->
 
<!--T:11-->
The {{MenuCommand|View}} tab shows visualization properties of the objects, which only affect their appearance in the [[3D view|3D view]].
+
*The {{MenuCommand|View}} tab shows visualization properties of the objects, which only affect their appearance in the [[3D view|3D view]].
  
 
<!--T:18-->
 
<!--T:18-->
The {{MenuCommand|Data}} tab shows the parametric properties of the objects, which determine how the geometrical shapes are defined.
+
*The {{MenuCommand|Data}} tab shows the parametric properties of the objects, which determine how the geometrical shapes are really defined.
  
 
<!--T:12-->
 
<!--T:12-->

Revision as of 05:26, 22 February 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

Introduction

The Combo view is one of the main panels in the FreeCAD interface. It is located on the left side of the screen by default. It is composed of two sections, the:

Note: originally the upper part (tree view) was separate from the lower part (property editor) but then they were combined, and thus the "combo" view was created.

Upper section

The Model tab shows the tree view, which is a representation of the document's content, including 2D and 3D geometry with their parametric history, but also supporting objects that contain data saved in the document.

The Tasks tab shows the task panel, which will show different actions depending on the active workbench, and the active tool.

FreeCAD Combo view Tree View properties.png FreeCAD Combo view Task panel.png

The combo view has two tabs: the Model tab that controls displaying the tree view and the property editor, and the Tasks tab that controls showing the task panel.


Lower section

The lower part of the combo view shows the property editor, which displays two tabs for View and Data properties. The property editor is only shown when the Model tab is active, that is, when the tree view is visible.

  • The View tab shows visualization properties of the objects, which only affect their appearance in the 3D view.
  • The Data tab shows the parametric properties of the objects, which determine how the geometrical shapes are really defined.

FreeCAD Combo view Tree View properties.png FreeCAD Combo view Tree Data properties.png

The lower part of the combo view is the property editor, which shows View and Data properties.


Disabling Combo view

To use these views by themselves use the parameter editor. Create the following subgroups if they don't exist

  • BaseApp/Preferences/DockWindows/TreeView
  • BaseApp/Preferences/DockWindows/PropertyView

then add the parameter Enabled of type Boolean, and set it to True.

Then activate the view using the menu, View → Panels → Tree view or → Property view.