Whiffle Мячик - Руководство

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Whiffle Ball tutorial and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский
Freecad.svg Руководство
Тема
Разработка продукта
Уровень
Начинающий
Время для завершения
30 минут
Авторы
r-frank и vocx
FreeCAD версия
0.17 и выше
Примеры файлов
WhiffleBall_Tutorial_FCWiki.FCStd

Введение

Этот учебник был первоначально написан Роландом Франком (†2017, r-frank), а затем переписан и проиллюстрирован vox.

Этот учебник создан чтобы научить вас использовать Верстак Part.

Верстак Part(Деталь) был первым разработанным верстаком. Он предоставляет основные геометрические элементы, которые могут быть использованы в качестве строительных блоков для других верстаков. Верстак Part предназначен для использования в традиционном рабочем процессе создания конструктивной твердотельной геометрии(CSG). Для более современного рабочего процесса с использованием эскизов, функции выдавливания и др. функций используйте верстак PartDesign.

Вы попрактикуетесь в:

  • вставке примитивов
  • изменении параметров этих примитивных объектов
  • изменении их размещения (положения в пространстве)
  • выполнении Булевых(логических) операций

10 T03 Part ball fillet.png

Окончательная модель wiffle мячика

Настройка

1. Откройте FreeCAD и создайте новый пустой документ с помощью Файл→ Std New.svg Создать новый, и переключитесь на верстак Part.

1.1. Нажмите на кнопкуStd ViewIsometric.svg изометрический Вид, или нажмите 0 на цифровой панели клавиатуры, для переключения в изометрический вид и лучшего представления 3D объектов.
1.2. Нажмите кнопку Std ViewFitAll.svg Уместить всё содержимое всякий раз, когда вы добавляете объекты для панорамирования и масштабирования 3D-вида, чтобы все элементы были видны на экране.
1.3. Удерживайте нажатой клавишу Ctrl, для выбора нескольких элементов. Если вы выбрали что-то неправильно или хотите отменить выбор всего, просто нажмите на пустое место в 3D-виде.

Вставка примитивных кубов

2. Вставьте примитивный куб, нажав на кнопку Part Box.svg Куб.

2.1. Выберите Куб в древе проекта.
2.2. Измените размеры во вкладке Данные на панели Окна свойств.
2.3. Измените Length(Длина) на90 мм.
2.4. Измените Width(Ширина) на 90 мм.
2.5. Измените Height(Высота) на 90 мм.

3. На вкладке Данные панели Окна свойств, нажмите на Placement(Размещение) так что бы появилась кнопка ... справа.

3.1. Нажмите на неё для запуска диалогового окна Placement(Размещение).
3.2. Измените значения Перемещения.
3.3. Измените X на -45 мм.
3.4. Измените Y на -45 мм.
3.5. Измените Z на -45 мм.
3.6. Нажмите кнопку OK для закрытия диалогового окна.

4. Повторите этот процесс ещё раз, вставив второй, меньший куб, нажав на кнопку Part Box.svg Куб.

4.1. Второй куб будет создан с тем же именем, но с дополнительным номером, чтобы различать объекты.
4.2. Выберите Куб001 в древе проекта, и измените его размеры и положение как и с предыдущим объектом.
4.3. Измените Length на 80 мм.
4.4. Измените Width на 80 мм.
4.5. Измените Height на 80 мм.
4.6. Откройте диалог Placement.
4.7. Измените X на -40 мм.
4.8. Измените Y на -40 мм.
4.9. Измените Z на -40 мм.
4.10. Нажмите кнопку OK для закрытия диалога.

Изменение визуальных свойств

5. В предыдущих операциях мы создали меньший куб внутри большего. Чтобы увидеть это, мы можем изменить свойства представления на вкладке Вид в панели Окна свойств.

5.1. Давайте выберем Куб001, меньший куб в древе проекта, и изменим его цвет. На вкладке Вид, щёлкните на значение Shape Color(Цвет Поверхности) чтобы открыть диалоговое окно Выбора цвета, затем выберите зелёный цвет; а так же измените значение Line Width(Толщина Линии) на 2.0.
5.2. Теперь выберите Куб больший куб, в древе проекта, и измените его прозрачность(transparency). Для этого на вкладке Вид, измените значение Transparency(Прозрачность) на 70.

01 T03 Part cubes visibility.png

Твердотельный куб внутри другого твердотельного куба

Вставка примитивных цилиндров

6. Давайте вставим простой цилиндр нажав на кнопку Part Cylinder.svg Цилиндр.

6.1. Выберите наш Цилиндр в древе проекта.
6.2. Теперь изменим размеры на вкладке Данные панели окна свойств.
6.3. Измените Radius(Радиус) на 27.5 мм.
6.4. Измените Height(Высоту) на 120 мм.
6.5. Теперь откройте диалоговое окно Placement(Расположение).
6.6. Изменим Z на -60 мм.
6.7. И нажмём кнопку OK для закрытия диалога.

7. Повторите процесс и вставьте второй цилиндр, нажав на кнопку Part Cylinder.svg Цилиндр.

7.1. Второй цилиндр будет создан с тем же именем, но с дополнительным номером, чтобы различать объекты.
7.2. Выберите наш Цилиндр001 в древе проекта, и измените его размеры и расположение как и с предыдущим.
7.3. Измените Radius на 27.5 мм.
7.4. Измените Height на 120 мм.
7.5. Откройте диалоговое окно Расположение.
7.6. Измените Y на 60 мм.
7.7. Измените параметр Вращение на Ось вращения с углом; и выберите Ось X, а также укажите Угол 90 град.
7.8. Затем нажмите кнопку OK чтобы закрыть даалог.

8. Давайте вставим ещё один цилиндр. В этот раз создадим дубликат, так что бы его радиус и длина остались прежними, а изменилось только его расположение.

8.1. Выберите Цилиндр001 в древе документа, и перейдите в меню Правка→ Дублировать выбранное. Эта команда создаст Цилиндр002.
8.2. Откройте диалог Placement(Расположение).
8.3. Измените X на -60 мм.
8.4. Измените параметр Вращение на Ось вращения с углом; и выберите Ось Y, а также укажите Угол 90 гард.
8.5. И нажмите кнопку OK для закрытия диалога.

Изменение визуальных свойств

9. Предыдущие операции создают три цилиндра, которые пересекаются друг с другом, а также пересекают кубы. Чтобы лучше увидеть это, мы можем изменить свойства представления в панели окна свойств.

9.1. Выберите Куб001, меньший куб, в древе проекта и измените прозрачность. На вкладке Вид измените значение Transparency(Прозрачности) на 70.
9.2. Выберите Цилиндр, на вкладке Вид нажмите на значение Shape Color(Цвет формы), чтобы открыть диалоговое окно Выбор цвета, а затем выберите красный цвет.
9.3. Выберите Цилиндр001, на вкладке Вид нажмите на значение Shape Color(Цвет формы), чтобы открыть диалоговое окно Выбор цвета, а затем выберите синий цвет.
9.4. Выберите Цилиндр002, на вкладке Вид нажмите на значение Shape Color(Цвет формы), чтобы открыть диалоговое окно Выбор цвета, а затем выберите розовый цвет.
9.5. Выберите все три цилиндра и на вкладке Вид, измените значение Line Width(Ширины Линии) на 2.0.

02 T03 Part cylinders visibility.png

Твердотельные цилиндры, которые пересекаются между собой и твердотельными кубами.

Объединение и вырезка

10. В древе проекта выберите Куб001 (внутренний, меньший куб) и три цилиндра, затем нажмите Part Fuse.svg Объединение(Fuse). Это создаст объект Fusion.

11. Затем выполните Булеву (логическую) обрезку Куба(большего куба) и нового объекта Fusion(слияния).

11.1. В древе проекта сначала выберите Куб, а затем Fusion.
11.2. Затем нажмите кнопку Part Cut.svg Обрезать. Это создаст объект Cut.
Примечание: порядок, в котором вы выбираете объекты, важен для операции вырезания. Сначала выбирается базовый объект, а потом вырезаемый.
11.3. Если цвета выглядят странно, выберите новый объект вырезки Cut, перейдите на вкладку Вид, нажмите на значение Shape Color(Цвета формы), чтобы открыть диалоговое окно Выбор цвета, затем выберите серый цвет; также измените значение Line Width(ширины линии) на 2.0.

03 T03 Part cube cut.png

Пустотелая форма, полученная вырезанием куба и трёх цилиндров из большего куба.

Вставка кубов для обрезки углов незаконченного тела

Теперь мы создадим ещё несколько кубиков, которые будут использоваться в качестве режущих инструментов для обрезки углов ранее полученного объекта Cut.

12. Нажмите на Part Box.svg Куб.

12.1. Выберите Куб002 в древе проекта, и измените его размеры и расположение.
12.2. Измените Length(Длина) на 140 мм.
12.3. Измените Width(Ширина) на 112 мм.
12.4. Измените Высота на 112 мм.
12.5. Откройте диалог Placement(Расположение).
12.6. Измените X на -70 мм.
12.7. Измените Y на -56 мм.
12.8. Измените Z на -56 мм.
12.9. Нажмите OK.

13. Нажмите на Part Box.svg Куб.

13.1. Выберите Куб003 в древе проекта, и измените его размеры и расположение.
13.2. Измените Length(Длина) на 180 мм.
13.3. Измените Width(Ширина) на 180 мм.
13.4. Измените Height(Высота) на 180 мм.
13.5. Откройте диалог Placement(Расположение).
13.6. Измените X на -90 мм.
13.7. Измените Y на -90 мм.
13.8. Измените Z на -90 мм.
13.9. Нажмите OK.

Мы снова продублируем два предыдущих объекта, чтобы еще раз использовать их в качестве режущих объектов.

14. Выберите только Куб002 в древе проекта и перейдите в меню Правка → Дублировать выбранное. Это создаст Куб004.

15. Выберите только Куб003 в древе проекта и перейдите в меню Правка → Дублировать выбранное. Это создаст Куб005.

16. Чтобы лучше увидеть это, мы можем изменить значения свойств на вкладке Вид в панели окна свойств.

16.1. Выберите вырезанный объект Cut, и на вкладке Вид нажмите на значение Shape Color(Цвета формы), чтобы открыть диалоговое окно Select color(Выбор цвета), а затем выберите синий цвет.
16.2. Выберите все новые кубы, Куб002, Куб003, Куб004 и Куб005, на вкладке Вид измените значение Transparency(Прозрачности )на 80.

04 T03 Part cube additional.png

Дополнительные внешние кубы, которые будут использоваться в качестве режущих объектов для внутреннего твердого тела.

Срезание углов 1

17. В древе проекта выберите Куб002 и Куб003.

17.1. Откройте диалог Placement(Расположение).
17.2. Отметьте опцию (поставьте галочку) Применить дополнительные изменения; обратите внимание, что все значения Перемещение сбрасываются на нули.
17.3. Измените Вращение на Ось вращения с углом; укажите Ось X, и Угол 45 град, затем нажмите Применить. Это применит вращение вокруг оси X, и сбросит значение Угла на ноль.
17.4. Измените ещё раз Вращение, но теперь вокруг Оси Z, и укажите Угол 45 град, затем нажмите Применить. Это применит вращение вокруг оси z, и сбросит значение Угла на ноль.
17.5. Нажмите OK для закрытия диалога.

18. В древе проекта отмените ранее выбранные объекты; а затем выберите сначала Куб003, больший куб, а затем Куб002, меньший куб.

18.1. Затем нажмите Part Cut.svg Обрезать. Это создаст Cut001. Это пустотелое тело, которое пересекает первоначальное тело Cut, только в определённых углах.

19. Чтобы лучше увидеть это, мы можем изменить свойства представления на вкладке Вид в окне свойств.

19.1. Выберите Куб004 и Куб005, на вкладке Вид, теперь измените значение свойства Visibility(Видимость) на false(ложь), или просто нажмите Space на клавиатуре.
19.2. Выберите Cut001, щёлкните на значение свойства Shape Color(Цвет формы) для открытия диалога Выбор цвета, затем выберите красный цвет; а также поменяйте значение Transparency(Прозрачность) на 90.

05 T03 Part cube additional cut 1.png

Повернутое, пустотелое твёрдое тело, которое будет использоваться в качестве режущего объекта для некоторых углов внутреннего твёрдого тела.

Срезание углов 2

20. В древе проекта выберите Cut001, на вкладке Вид измените значение Visibility(Видимость) на false(ложь) или нажмите Space(Пробел) на клавиатуре.

21. В древе проекта выберите Куб004 и Куб005, на вкладке Вид измените значение Visibility(Видимость)на true(истина) или просто нажмите Space(Пробел) на клавиатуре.

21.1. Откройте диалог Расположение.
21.2. Отметьте опцию (поставьте галочку) Применить дополнительные изменения; обратите внимание, что все значения Перемещение сбрасываются на нули.
21.3. Измените Вращение на Ось вращения с углом; укажите Ось X, и Угол 45 град, затем нажмите Применить. Это применит вращение вокруг оси X, и сбросит значение Угла на ноль.
21.4. Измените ещё раз Вращение, но теперь вокруг Оси Z, и укажите Угол -45 град, затем нажмите Применить. Это применит вращение вокруг оси z, и сбросит значение Угла на ноль.
21.5. Нажмите OK для закрытия диалога.

22. В древе проекта отмените ранее выбранные объекты; а затем выберите сначала Куб005, больший куб, а затем Куб004, меньший куб.

22.1. Затем нажмите Part Cut.svg Обрезать. Это создаст Cut002. Это пустотелое тело, которое пересекает первоначальное тело Cut, только в определённых углах.

23. Чтобы лучше увидеть это, мы можем изменить свойства представления на вкладке Вид в окне свойств.

23.1. Выберите Cut002, щёлкните на значение свойства Shape Color(Цвет формы) для открытия диалога Выбор цвета, затем выберите розовый цвет; а также поменяйте значение Transparency(Прозрачность) на 90.

06 T03 Part cube additional cut 2.png

Повернутое, пустотелое твёрдое тело, которое будет использоваться в качестве режущего объекта для некоторых углов внутреннего твёрдого тела.

Завершаем модель

24. Убедитесь что все объекты видимые. В древе проекта выберите все объекты, на вкладке Вид, измените значение Visibility(Видимость) на true(истина), или нажмите Пробел на клавиатуре.

07 T03 Part ball additional both.png

Внутреннее пустотелое твёрдое тело вместе с внешними телами, которые будут использоваться для его резки.

25. В древе проектадреве проекта снимите выделение со всех объектов; затем первым выберите Cut, а потом Cut001.

25.1. Затем нажмите Part Cut.svg Обрезать. Это создаст Cut003.

08 T03 Part ball cut 1.png

Внутреннее тело, обрезанное Cut001.

26. В древе проекта снимите выделение с объектов, затем выберите сначала Cut003, а затем Cut002.

26.1. Затем нажмите Part Cut.svg Обрезать. Это создаст Cut004. Это окончательная модель.
26.2. Выберите Cut004, щёлкните на значение Shape Color(Цвет Формы) для открытия диалога Выбор цвета, затем выберите зелёный цвет; а также поменяйте значение Line Width(Толщина Линии) на 2.0.

09 T03 Part ball cut 2.png

Внутреннее полое твердое тело, вырезанное Cut001 и Cut002. Окончательная модель.

27. Реальные объекты не имеют идеально острых краев или углов, поэтому применение скругления к краям может быть сделано для уточнения модели.

27.1. В древе проекта, выберите Cut004 и нажмите

Part Fillet.svg Скругление.

27.2. На панели задач Скруглить рёбера перейдите в раздел Выделение, выберите Выбрать рёбра и нажмите Все. В качестве Тип скругления выберите Постоянный радиус, затем установите Радиус равным 1 мм.
24.3. Нажмите OK. Это создаст объект Fillet.
27.4. На вкладке Вид, измените значение Line Width(Толщина Линии) на 2.0.

10 T03 Part ball fillet.png

Окончательная модель whiffle ball (шарик дуновения) со скруглениями на кромках.