Tutoriel balle Whiffle

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Whiffle Ball tutorial and the translation is 14% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Base ExampleCommandModel.png Tutoriel
Thème
Conception de produits
Niveau
Débutant
Temps d'exécution estimé
30 minutes
Auteur(s)
r-frank et vocx
Version de FreeCAD
0.17 et plus
Fichier(s) exemple(s)
WhiffleBall_Tutorial_FCWiki.FCStd


Introduction

Ce tutoriel a été écrit à l'origine par Roland Frank († 2017, r-frank). Il a été réécrit et illustré par vocx.

Ce tutoriel est là pour vous apprendre à utiliser l'atelier Part.

L'atelier Part a été le premier atelier. Il fournit les éléments géométriques de base qui peuvent être utilisés comme blocs de construction pour d’autres ateliers. L'atelier Part est destiné à être utilisé dans un flux de travaux Géométrie Solide Constructive CSG traditionnel. Pour un flux de travail plus moderne utilisant des esquisses, des blocs et des fonctions, utilisez l'atelier PartDesign.

Vous vous exercerez à :

  • insérer des primitives
  • en modifiant les paramètres de ces objets primitifs
  • en modifiant leur placement
  • au moyen d'opérations booléennes

10 T03 Part ball fillet.png

Modèle final de la balle wiffle


Mettre en place la forme de base

  1. Basculez dans l'atelier Part
  2. Créez un nouveau document par le menu Fichier → Nouveau
  3. Insérez un cube en cliquant sur Part Box.png
  4. Assurez vous que le cube ("Cube") est sélectionné dans la vue arborescente
  5. Changez les dimensions du cube (dans Propriétés/Onglet Données) en
    1. Length= 90 mm
    2. Width= 90 mm
    3. Heigth= 90 mm
  6. Cliquez sur la valeur du champ "Placement" afin que ... apparaisse à droite
  7. Cliquez sur ... pour changer la position du cube (translation)
    1. X: -45 mm
    2. Y: -45 mm
    3. Z: -45 mm
  8. Cliquez sur OK pour fermer la boite de dialogue
  9. Insérez un cube ("Cube001") en cliquant sur Part Box.png
  10. Assurez vous que le cube ("Cube001") est sélectionné dans la vue arborescente
  11. Changez les dimensions du cube (dans Propriétés/Onglet Données) en
    1. Length= 80 mm
    2. Width= 80 mm
    3. Heigth= 80 mm
  12. Changez la position du cube ("Cube001") en
    1. X: -40 mm
    2. Y: -40 mm
    3. Z: -40 mm
  13. Cliquez sur Part Cylinder.png pour insérer un cylindre ("Cylindre")
  14. Assurez vous que le cylindre ("Cylindre") est sélectionné dans la vue arborescente
  15. Changez le rayon (radius) de "Cylindre" en 27,5 mm, changez sa hauteur (height) en 120 mm
  16. Changez la position de "Cylindre" en
    1. X: 0 mm
    2. Y: 0 mm
    3. Z: -60 mm
  17. Cliquez sur Part Cylinder.png pour insérer un cylindre ("Cylindre001")
  18. Changez le rayon (radius) de "Cylindre001" en 27,5 mm, changez sa hauteur (height) en 120 mm
  19. Choisissez Édition → Dupliquer la sélection depuis le menu supérieur pour avoir un autre cylindre ("Cylindre002")
  20. Assurez vous que le cylindre ("Cylindre001") est sélectionné dans la vue arborescente
  21. Changez la position de "Cylindre001" en
    1. Y: 60 mm
    2. Rotation de l'axe selon un angle
    3. Axe: X
    4. Angle: 90°
  22. Cliquez sur OK pour appliquer les valeurs et fermez la boite de dialogue
  23. Assurez vous que le cylindre ("Cylindre002") est sélectionné dans la vue arborescente
  24. Changez la position de "Cylindre002" en
    1. X: -60 mm
    2. Rotation de l'axe selon un angle
    3. Axis: Y
    4. Angle: 90°
  25. Cliquez sur OK pour appliquer les valeurs et fermer la boite de dialogue
  26. Cliquez sur View-axometric.png pour passer en vue axonométrique
  27. Cliquer sur View-zoom-all.png pour adapter le zoom à la taille de la pièce
  28. Sélectionnez "Cube001", "Cylindre", "Cylindre001" et "Cylindre002" et fusionnez les en cliquant sur Part Fuse.png
  29. Sélectionnez "Cube" et "Fusion", mais soyez sûr de sélectionner "Cube" en PREMIER
  30. Appliquez une soustraction booléenne en cliquant sur Part Cut.png

Astuce : Si vous sélectionnez quelque chose qui ne convient pas ou voulez simplement désélectionner tout,
cliquez juste (Style de navigation OpenInventor : CTRL-Click) dans un espace vide de la vue 3D.

Insert primitive cubes

2. Insert a primitive cube by clicking on Part Box.svg Box.

2.1. Select Cube in the tree view.
2.2. Change the dimensions in the Data tab of the property editor.
2.3. Change Length to 90 mm.
2.4. Change Width to 90 mm.
2.5. Change Height to 90 mm.

3. In the Data tab of the property editor, click on the Placement value so the ellipsis button ... appears on the right.

3.1. Press on the ellipsis to launch the Placement dialog.
3.2. Change the Translation values.
3.3. Change X to -45 mm.
3.4. Change Y to -45 mm.
3.5. Change Z to -45 mm.
3.6. Press the OK button to close the dialog.

4. Repeat the process, inserting a second, smaller cube by clicking on Part Box.svg Box.

4.1. The second cube will be created with the same name, but with an additional number to distinguish the object.
4.2. Select Cube001 in the tree view, and change the dimensions and placement like with the previous object.
4.3. Change Length to 80 mm.
4.4. Change Width to 80 mm.
4.5. Change Height to 80 mm.
4.6. Open the Placement dialog.
4.7. Change X to -40 mm.
4.8. Change Y to -40 mm.
4.9. Change Z to -40 mm.
4.10. Press the OK button to close the dialog.

Change visual properties

5. The previous operations create a smaller cube inside a bigger cube. To visualize this, we can modify the View properties in the property editor.

5.1. Select Cube001, the smaller cube, in the tree view, and change the color. In the View tab, click on the Shape Color value to open the Select color dialog, then choose a green color; also change the value of Line Width to 2.0.
5.2. Select Cube, the larger cube, in the tree view, and change the transparency. In the View tab, change the value of Transparency to 70.

01 T03 Part cubes visibility.png

Solid cube inside another solid cube


Insert primitive cylinders

6. Insert a primitive cylinder by clicking on Part Cylinder.svg Cylinder.

6.1. Select Cylinder in the tree view.
6.2. Change the dimensions in the Data tab of the property editor.
6.3. Change Radius to 27.5 mm.
6.4. Change Height to 120 mm.
6.5. Open the Placement dialog.
6.6. Change Z to -60 mm.
6.7. Press the OK button to close the dialog.

7. Repeat the process, inserting a second cylinder by clicking on Part Cylinder.svg Cylinder.

7.1. The second cylinder will be created with the same name, but with an additional number to distinguish the object.
7.2. Select Cylinder001 in the tree view, and change the dimensions and placement like with the previous object.
7.3. Change Radius to 27.5 mm.
7.4. Change Height to 120 mm.
7.5. Open the Placement dialog.
7.6. Change Y to 60 mm.
7.7. Change the Rotation to Rotation axis with angle; Axis to X, and Angle to 90 deg.
7.8. Press the OK button to close the dialog.

8. Insert another cylinder. This time create a duplicate so that the radius and height don't have to be changed, only its placement.

8.1. Select Cylinder001 in the tree view, and go to the menu Edit → Duplicate selection. This will create Cylinder002.
8.2. Open the Placement dialog.
8.3. Change X to -60 mm.
8.4. Change the Rotation to Rotation axis with angle; Axis to Y, and Angle to 90 deg.
8.5. Press the OK button to close the dialog.

Change visual properties

9. The previous operations create three cylinders that intersect with each other, and also intersect the cubes. To visualize this better we can modify the View properties in the property editor.

9.1. Select Cube001, the smaller cube, in the tree view, and change the transparency. In the View tab, change the value of Transparency to 70.
9.2. Select Cylinder, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a red color.
9.3. Select Cylinder001, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a blue color.
9.4. Select Cylinder002, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a pink color.
9.5. Select the three cylinders, in the View tab also change the value of Line Width to 2.0.

02 T03 Part cylinders visibility.png

Solid cylinders that intersect themselves and the solid cubes.


Fuse and cut

10. In the tree view, select Cube001 (the inner, smaller cube), and the tree cylinders, then press Part Fuse.svg Fuse. This will create a Fusion object.

11. Then perform a boolean cut of the Cube (larger cube) and the new Fusion object.

11.1. In the tree view select Cube first, and then Fusion.
11.2. Then press Part Cut.svg Cut. This will create a Cut object.
Note: the order in which you select the objects is important for the cut operation. The base object is selected first, and the subtracting object comes at the end.
11.3. If the colors look strange, select the new Cut object, go to the View tab, click on the Shape Color value to open the Select color dialog, then choose a gray color; also change the value of Line Width to 2.0.

03 T03 Part cube cut.png

La forme de base terminée doit ressembler à ça :

Insert primitive cubes to cut the corners of the partial solid

Now we'll create more cubes that will be used as cutting tools to trim the corners of the previously obtained Cut object.

12. Click on Part Box.svg Box.

12.1. Select Cube002 in the tree view, and change the dimensions and placement.
12.2. Change Length to 140 mm.
12.3. Change Width to 112 mm.
12.4. Change Height to 112 mm.
12.5. Open the Placement dialog.
12.6. Change X to -70 mm.
12.7. Change Y to -56 mm.
12.8. Change Z to -56 mm.
12.9. Press OK.

13. Click on Part Box.svg Box.

13.1. Select Cube003 in the tree view, and change the dimensions and placement.
13.2. Change Length to 180 mm.
13.3. Change Width to 180 mm.
13.4. Change Height to 180 mm.
13.5. Open the Placement dialog.
13.6. Change X to -90 mm.
13.7. Change Y to -90 mm.
13.8. Change Z to -90 mm.
13.9. Press OK.

We'll duplicate the previous two objects again to use once more as cutting objects.

14. Select only Cube002 in the tree view, and go to Edit → Duplicate selection. This will create Cube004.

15. Select only Cube003 in the tree view, and go to Edit → Duplicate selection. This will create Cube005.

16. To visualize this better we can modify the View properties in the property editor.

16.1. Select the Cut object, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a blue color.
16.2. Select all new cubes, Cube002, Cube003, Cube004, and Cube005, in the View tab, change the value of Transparency to 80.

04 T03 Part cube additional.png

Additional external cubes that will be used as cutting objects for the internal solid.


Couper les coins partie 1

  1. Insérez un cube ("Cube002") en cliquant sur Part Box.png
  2. Changez les dimensions du cube ("Cube002") (voir Propriétés/Onglet Données) en
    1. Length= 140 mm
    2. Width= 112 mm
    3. Heigth= 112 mm
  3. Changez la position du cube ("Cube002") en
    1. X: -70 mm
    2. Y: -56 mm
    3. Z: -56 mm
  4. Insérez un cube ("Cube003") en cliquant sur Part Box.png
  5. Changez les dimensions du cube ("Cube003") (voir Propriétés/Onglet Données) en
    1. Length= 180 mm
    2. Width= 180 mm
    3. Heigth= 180 mm
  6. Changez la position du cube ("Cube003") en
    1. X: -90 mm
    2. Y: -90 mm
    3. Z: -90 mm
  7. Assurez-vous que "Cube002" est sélectionné dans la vue arborescente, sinon sélectionnez le
  8. Choisissez Édition → Dupliquer la sélection depuis le menu supérieur pour obtenir un autre cube ("Cube004")
  9. Assurez-vous que "Cube003" est sélectionné dans la vue arborescente, sinon sélectionnez le
  10. Choisissez Édition → Dupliquer la sélection depuis le menu supérieur pour obtenir un autre cube ("Cube005")
  11. Sélectionnez "Cube003" et "Cube002", mais attention, sélectionnez "Cube003" en PREMIER
  12. Allez dans le menu placement ...
  13. cochez la case Appliquez les modifications incrémentielles au placement de l'objet
  14. Faites une rotation de 45° autour de l'axe X puis cliquez sur Apply
  15. Faites une rotation de 45° autour de l'axe Z puis cliquez sur Apply
  16. Cliquez sur OK pour fermer la fenêtre de dialogue
  17. Appliquez une soustraction booléenne en cliquant sur Part Cut.png, l'objet résultant sera nommé "Cut001"

17. In the tree view select Cube002 and Cube003.

17.1. Open the Placement dialog.
17.2. Tick the option Apply incremental changes; notice that all Translation values are reset to zeroes.
17.3. Change the Rotation to Rotation axis with angle; Axis to X, and Angle to 45 deg, then click on Apply. This will apply a rotation around the X-axis, and will reset the Angle field to zero.
17.4. Change the Rotation again, now Axis to Z, and Angle to 45 deg, then click on Apply. This will apply a rotation around the local Z-axis, and will reset the Angle field to zero.
17.5. Click on OK to close the dialog.

18. In the tree view de-select the objects; then select Cube003 first, the bigger cube, and then Cube002, the smaller cube.

18.1. Then press Part Cut.svg Cut. This will create Cut001. This is a hollowed body which intersects the initial Cut only at certain corners.

19. To visualize this better we can modify the View properties in the property editor.

19.1. Select Cube004 and Cube005, in the View tab, then change the value of Visibility to false, or press Space in the keyboard.
19.2. Select Cut001, click on the Shape Color value to open the Select color dialog, then choose a red color; also change the value of Transparency to 90.

05 T03 Part cube additional cut 1.png

A rotated, hollowed solid, which will be used as a cutting object for some corners of the internal solid.


Couper les coins partie 2

  1. Sélectionnez "Cube005" et "Cube004", mais attention, sélectionnez "Cube005" en PREMIER
  2. Allez dans le menu placement ...
  3. cochez la case Appliquez les modifications incrémentielles au placement de l'objet, notez que toutes les valeurs sont réinitialisées ...
  4. Faites une rotation de 45° autour de l'axe X puis cliquez sur Apply
  5. Faites une rotation de -45° autour de l'axe Z puis cliquez sur Apply
  6. Cliquez sur OK pour fermer la fenêtre de dialogue
  7. Appliquez une soustraction booléenne en cliquant Part Cut.png, l'objet résultant sera nommé "Cut002"
  8. Cliquez sur View-axometric.png pour se mettre en vue axonométrique
  9. Cliquez sur View-zoom-all.png pour que le zoom soit automatiquement à l'échelle de la pièce

20. In the tree view select Cut001, in the View tab, change the value of Visibility to false, or press Space in the keyboard.

21. In the tree view select Cube004 and Cube005, in the View tab, change the value of Visibility to true, or press Space in the keyboard.

21.1. Open the Placement dialog.
21.2. Tick the option Apply incremental changes; notice that all Translation values are reset to zeroes.
21.3. Change the Rotation to Rotation axis with angle; Axis to X, and Angle to 45 deg, then click on Apply. This will apply a rotation around the X-axis, and will reset the Angle field to zero.
21.4. Change the Rotation again, now Axis to Z, and Angle to -45 deg, then click on Apply. This will apply a rotation around the local Z-axis, and will reset the Angle field to zero.
21.5. Click on OK to close the dialog.

22. In the tree view de-select the objects; then select Cube005 first, the bigger cube, and then Cube004, the smaller cube.

22.1. Then press Part Cut.svg Cut. This will create Cut002. This is a hollowed body which intersects the initial Cut only at certain corners.

23. To visualize this better we can modify the View properties in the property editor.

23.1. Select Cut002, click on the Shape Color value to open the Select color dialog, then choose a pink color; also change the value of Transparency to 90.

06 T03 Part cube additional cut 2.png

Si tout s'est bien passé, votre modèle doit ressembler à ça :

Finalisation du modèle

  1. Sélectionnez "Cut" et "Cut001", mais attention, sélectionnez "Cut" en PREMIER
  2. Appliquez une soustraction booléenne en cliquant sur Part Cut.png, l'objet résultant sera nommé "Cut003"
  3. Sélectionnez "Cut003" et "Cut002", mais attention, sélectionnez "Cut003" en PREMIER
  4. Appliquer une soustraction booléenne en cliquant sur Part Cut.png, l'objet résultant sera nommé "Cut004"
  5. Cliquez sur View-axometric.png pour changer la vue en vue axonométrique
  6. Cliquez sur View-zoom-all.png pour que le zoom soit automatiquement à l'échelle de la pièce
  7. N'oubliez pas de sauvegarder votre fichier...

24. Make sure all objects are visible. In the tree view select all objects, in the View tab, change the value of Visibility to true, or press Space in the keyboard.

07 T03 Part ball additional both.png

The internal hollowed solid, together with the external objects which will be used to cut it.


25. In the tree view de-select the objects; then select Cut first, and then Cut001.

25.1. Then press Part Cut.svg Cut. This will create Cut003.

08 T03 Part ball cut 1.png

The internal hollowed solid, cut by Cut001.


26. In the tree view de-select the objects; then select Cut003 first, and then Cut002.

26.1. Then press Part Cut.svg Cut. This will create Cut004. This is the final object.
26.2. Select Cut004, click on the Shape Color value to open the Select color dialog, then choose a green color; also change the value of Line Width to 2.0.

09 T03 Part ball cut 2.png

The internal hollowed solid, cut by Cut001 and Cut002. Final model.


27. Real objects don't have perfectly sharp edges or corners, so applying a fillet to the edges can be done to refine the model.

27.1. In the tree view, select Cut004 then press Part Fillet.svg Fillet.
27.2. In the Fillet edges task panel go to Selection, choose Select edges, and then press All. As Fillet type choose Constant radius, then set Radius to 1 mm.
24.3. Press OK. This will create a Fillet object.
27.4. In the View tab, change the value of Line Width to 2.0.

10 T03 Part ball fillet.png

Final whiffle ball model with fillets applied to the edges.