Whiffle Ball Tutorial

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Whiffle Ball tutorial and the translation is 2% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Einleitung

Diese Übung soll dazu dienen, den Arbeitsbereich "Part" (Part Module/de) kennen zu lernen. Sie werden lernen:

  • Grundkörper einzufügen
  • deren Abmaße zu verändern
  • die Körper im Raum per "Placement" zu positionieren
  • boolsche Operationen mit Körpern durchzuführen

This tutorial was originally written by Roland Frank (†2017, r-frank), and it was rewritten and illustrated by vocx.

This tutorial is here to teach you how to use the Part Workbench.

The Part Workbench was the first workbench developed. It provides the basic geometrical elements that can be used as building blocks for other workbenches. The Part Workbench is meant to be used in a traditional constructive solid geometry (CSG) workflow. For a more modern workflow using sketches, pads, and features, use the PartDesign Workbench.

You will practice:

  • inserting primitives
  • changing parameters of those primitive objects
  • modifying their placement
  • doing boolean operations

10 T03 Part ball fillet.png

Final model of the wiffle ball


Den Grundkörper herstellen

  1. Wechseln Sie in den Arbeitsbereich Part (Part Module)
  2. Erstellen Sie eine neues Dokument über das Menü Datei → Neu
  3. Fügen Sie einen Würfel ein durch Klick auf Part Box.png
  4. Stellen Sie sicher, dass der Würfel ("Cube") in der Baumansicht ausgewählt ist
  5. Ändern Sie die Abmessungen des Würfels ("Cube") (über den Daten-Reiter) wie folgt
    1. Länge= 90 mm
    2. Breite= 90 mm
    3. Höhe= 90 mm
  6. Klicken Sie in das Zahlen-Feld der Placement-Eigenschaft, damit ... rechts von dem Zahlen-Feld erscheinen
  7. Klicken Sie auf ..., um das Placement des Würfels zu ändern
    1. X: -45 mm
    2. Y: -45 mm
    3. Z: -45 mm
  8. Klicken Sie auf OK, um den Dialog zu schließen
  9. Fügen Sie einen Würfel ("Cube001") ein durch Klick auf Part Box.png
  10. Stellen Sie sicher, dass der Würfel ("Cube001") in der Baumansicht ausgewählt ist
  11. Ändern Sie die Abmessungen des Würfels ("Cube001") (über den Daten-Reiter) wie folgt
    1. Länge= 80 mm
    2. Breite= 80 mm
    3. Höhe= 80 mm
  12. Ändern Sie das Placement des Würfels ("Cube001") auf
    1. X: -40 mm
    2. Y: -40 mm
    3. Z: -40 mm
  13. Klicken Sie auf Part Cylinder.png, um einen Zylinder ("Cylinder") einzufügen
  14. Stellen Sie sicher, dass der Zylinder ("Cylinder") in der Baumansicht ausgewählt ist
  15. Ändern Sie den Radius des Zylinders auf 27,5 mm, ändern Sie die Höhe auf 120 mm
  16. Ändern Sie die Placement-Werte des Zylinders ("Cylinder") auf
    1. X: 0 mm
    2. Y: 0 mm
    3. Z: -60 mm
  17. Klicken Sie auf Part Cylinder.png, um einen Zylinder ("Cylinder001") einzufügen
  18. Ändern Sie den Radius des Zylinders auf 27,5 mm, ändern Sie die Höhe auf 120 mm
  19. Wählen Sie Bearbeiten → Auswahl duplizieren aus dem obersten Menü in FreeCAD, um einen weiteren Zylinder ("Cylinder002") zu erhalten
  20. Stellen Sie sicher, dass "Cylinder001" in der Baumansicht ausgewählt ist
  21. Ändern Sie die Placement-Werte des Zylinders ("Cylinder001") auf
    1. y: 60 mm
    2. Drehung= Rotationsachse mit Winkel
    3. Achse: X
    4. Winkel: 90°
  22. Klicken Sie auf OK zum Anwenden der Werte und Schließen des Dialoges
  23. Stellen Sie sicher, dass "Cylinder002" in der Baumansicht ausgewählt ist
  24. Ändern Sie die Placement-Werte des Zylinders ("Cylinder002") auf
    1. X: -60 mm
    2. Drehung=Rotationsachse mit Winkel
    3. Achse: Y
    4. Winkel: 90°
  25. Klicken Sie auf OK zum Anwenden der Werte und Schließen des Dialoges
  26. Klicken Sie auf View-axometric.png, um zur axonometrischen Ansicht zu wechseln
  27. Klicken Sie auf View-zoom-all.png, um auf das ganze Modell zu zoomen
  28. Wählen Sie "Cube001", "Cylinder", "Cylinder001" und "Cylinder002" in der Baumansicht aus und vereinigen Sie sie durch Klick auf Part Fuse.png
  29. Wählen Sie "Würfel" und "Fusion", aber stellen Sie sicher, dass "Würfel" ZUERST ausgewählt wurde
  30. Fügen Sie eine Verschneidung hinzu durch Klick auf Part Cut.png
  31. Das fertige Modell sollte so aussehen (Screenshot der engl. Version):

Tip: Wenn etwas Falsches ausgewählt wurde oder das Ausgewählte schnell de-selektiert werden soll
einfach in den leeren Raum in dem 3D-Fenster klicken (Navigation-Style OpenInventor: CTRL-Click).

Insert primitive cubes

2. Insert a primitive cube by clicking on Part Box.svg Box.

2.1. Select Cube in the tree view.
2.2. Change the dimensions in the Data tab of the property editor.
2.3. Change Length to 90 mm.
2.4. Change Width to 90 mm.
2.5. Change Height to 90 mm.

3. In the Data tab of the property editor, click on the Placement value so the ellipsis button ... appears on the right.

3.1. Press on the ellipsis to launch the Placement dialog.
3.2. Change the Translation values.
3.3. Change X to -45 mm.
3.4. Change Y to -45 mm.
3.5. Change Z to -45 mm.
3.6. Press the OK button to close the dialog.

4. Repeat the process, inserting a second, smaller cube by clicking on Part Box.svg Box.

4.1. The second cube will be created with the same name, but with an additional number to distinguish the object.
4.2. Select Cube001 in the tree view, and change the dimensions and placement like with the previous object.
4.3. Change Length to 80 mm.
4.4. Change Width to 80 mm.
4.5. Change Height to 80 mm.
4.6. Open the Placement dialog.
4.7. Change X to -40 mm.
4.8. Change Y to -40 mm.
4.9. Change Z to -40 mm.
4.10. Press the OK button to close the dialog.

Change visual properties

5. The previous operations create a smaller cube inside a bigger cube. To visualize this, we can modify the View properties in the property editor.

5.1. Select Cube001, the smaller cube, in the tree view, and change the color. In the View tab, click on the Shape Color value to open the Select color dialog, then choose a green color; also change the value of Line Width to 2.0.
5.2. Select Cube, the larger cube, in the tree view, and change the transparency. In the View tab, change the value of Transparency to 70.

01 T03 Part cubes visibility.png

Solid cube inside another solid cube


Insert primitive cylinders

6. Insert a primitive cylinder by clicking on Part Cylinder.svg Cylinder.

6.1. Select Cylinder in the tree view.
6.2. Change the dimensions in the Data tab of the property editor.
6.3. Change Radius to 27.5 mm.
6.4. Change Height to 120 mm.
6.5. Open the Placement dialog.
6.6. Change Z to -60 mm.
6.7. Press the OK button to close the dialog.

7. Repeat the process, inserting a second cylinder by clicking on Part Cylinder.svg Cylinder.

7.1. The second cylinder will be created with the same name, but with an additional number to distinguish the object.
7.2. Select Cylinder001 in the tree view, and change the dimensions and placement like with the previous object.
7.3. Change Radius to 27.5 mm.
7.4. Change Height to 120 mm.
7.5. Open the Placement dialog.
7.6. Change Y to 60 mm.
7.7. Change the Rotation to Rotation axis with angle; Axis to X, and Angle to 90 deg.
7.8. Press the OK button to close the dialog.

8. Insert another cylinder. This time create a duplicate so that the radius and height don't have to be changed, only its placement.

8.1. Select Cylinder001 in the tree view, and go to the menu Edit → Duplicate selection. This will create Cylinder002.
8.2. Open the Placement dialog.
8.3. Change X to -60 mm.
8.4. Change the Rotation to Rotation axis with angle; Axis to Y, and Angle to 90 deg.
8.5. Press the OK button to close the dialog.

Change visual properties

9. The previous operations create three cylinders that intersect with each other, and also intersect the cubes. To visualize this better we can modify the View properties in the property editor.

9.1. Select Cube001, the smaller cube, in the tree view, and change the transparency. In the View tab, change the value of Transparency to 70.
9.2. Select Cylinder, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a red color.
9.3. Select Cylinder001, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a blue color.
9.4. Select Cylinder002, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a pink color.
9.5. Select the three cylinders, in the View tab also change the value of Line Width to 2.0.

02 T03 Part cylinders visibility.png

Solid cylinders that intersect themselves and the solid cubes.


Fuse and cut

10. In the tree view, select Cube001 (the inner, smaller cube), and the tree cylinders, then press Part Fuse.svg Fuse. This will create a Fusion object.

11. Then perform a boolean cut of the Cube (larger cube) and the new Fusion object.

11.1. In the tree view select Cube first, and then Fusion.
11.2. Then press Part Cut.svg Cut. This will create a Cut object.
Note: the order in which you select the objects is important for the cut operation. The base object is selected first, and the subtracting object comes at the end.
11.3. If the colors look strange, select the new Cut object, go to the View tab, click on the Shape Color value to open the Select color dialog, then choose a gray color; also change the value of Line Width to 2.0.

03 T03 Part cube cut.png

Die fertige Grundform sollte wie folgt aussehen:

Insert primitive cubes to cut the corners of the partial solid

Now we'll create more cubes that will be used as cutting tools to trim the corners of the previously obtained Cut object.

12. Click on Part Box.svg Box.

12.1. Select Cube002 in the tree view, and change the dimensions and placement.
12.2. Change Length to 140 mm.
12.3. Change Width to 112 mm.
12.4. Change Height to 112 mm.
12.5. Open the Placement dialog.
12.6. Change X to -70 mm.
12.7. Change Y to -56 mm.
12.8. Change Z to -56 mm.
12.9. Press OK.

13. Click on Part Box.svg Box.

13.1. Select Cube003 in the tree view, and change the dimensions and placement.
13.2. Change Length to 180 mm.
13.3. Change Width to 180 mm.
13.4. Change Height to 180 mm.
13.5. Open the Placement dialog.
13.6. Change X to -90 mm.
13.7. Change Y to -90 mm.
13.8. Change Z to -90 mm.
13.9. Press OK.

We'll duplicate the previous two objects again to use once more as cutting objects.

14. Select only Cube002 in the tree view, and go to Edit → Duplicate selection. This will create Cube004.

15. Select only Cube003 in the tree view, and go to Edit → Duplicate selection. This will create Cube005.

16. To visualize this better we can modify the View properties in the property editor.

16.1. Select the Cut object, in the View tab, click on the Shape Color value to open the Select color dialog, then choose a blue color.
16.2. Select all new cubes, Cube002, Cube003, Cube004, and Cube005, in the View tab, change the value of Transparency to 80.

04 T03 Part cube additional.png

Additional external cubes that will be used as cutting objects for the internal solid.


Ecken abschneiden Teil 1

  1. Fügen Sie einen Würfel ("Cube002") ein durch Klick auf Part Box.png
  2. Ändern Sie die Abmessungen des Würfels ("Cube002") (siehe Eigenschaft/Daten-Reiter) auf
    1. Länge= 140 mm
    2. Breite= 112 mm
    3. Höhe= 112 mm
  3. Ändern Sie die Placement-Werte des Würfels ("Cube002") auf
    1. X: -70 mm
    2. Y: -56 mm
    3. Z: -56 mm
  4. Fügen Sie einen Würfel ("Cube003") ein durch Klick auf Part Box.png
  5. Ändern Sie die Abmessungen des Würfels ("Cube003") (siehe Eigenschaft/Daten-Reiter) auf
    1. Länge= 180 mm
    2. Breite= 180 mm
    3. Höhe= 180 mm
  6. Ändern Sie die Placement-Werte des Würfels ("Cube003") auf
    1. X: -90 mm
    2. Y: -90 mm
    3. Z: -90 mm
  7. Stellen Sie sicher, dass "Cube002" in der Baumansicht ausgewählt ist, ansonsten bitte auswählen
  8. Wählen Sie Edit → Auswahl duplizieren aus dem obersten Menü, um einen weiteren Würfel ("Cube004") zu erhalten
  9. Stellen Sie sicher, dass "Würfel003" in der Baumansicht ausgewählt ist, ansonsten bitte auswählen
  10. Wählen Sie Edit → Auswahl duplizieren aus dem obersten Menü, um einen weiteren Würfel ("Cube005") zu erhalten
  11. Wählen Sie "Cube003" und "Cube002" aus, stellen Sie dabei sicher, dass "Cube003" ZUERST ausgewählt wurde
  12. Aktivieren Sie das Menü zum Ändern des Placement-Werts
  13. Wählen Sie die Option "Änderungen an Objekt-Placement inkrementell übernehmen" aus (die Placement-Werte werden dabei genullt)
  14. Wählen Sie "Rotation: X-Achse" und "Winkel: 45°" aus und klicken Sie auf Anwenden
  15. Wählen Sie "Rotation: Z-Achse" und "Winkel: 45°" aus und klicken Sie auf Anwenden
  16. Klicken Sie auf OK, um den Dialog zu schließen
  17. Erzeugen Sie eine Verschneidung durch Klick auf Part Cut.png, das resultierende Objekt heißt "Cut001"

17. In the tree view select Cube002 and Cube003.

17.1. Open the Placement dialog.
17.2. Tick the option Apply incremental changes; notice that all Translation values are reset to zeroes.
17.3. Change the Rotation to Rotation axis with angle; Axis to X, and Angle to 45 deg, then click on Apply. This will apply a rotation around the X-axis, and will reset the Angle field to zero.
17.4. Change the Rotation again, now Axis to Z, and Angle to 45 deg, then click on Apply. This will apply a rotation around the local Z-axis, and will reset the Angle field to zero.
17.5. Click on OK to close the dialog.

18. In the tree view de-select the objects; then select Cube003 first, the bigger cube, and then Cube002, the smaller cube.

18.1. Then press Part Cut.svg Cut. This will create Cut001. This is a hollowed body which intersects the initial Cut only at certain corners.

19. To visualize this better we can modify the View properties in the property editor.

19.1. Select Cube004 and Cube005, in the View tab, then change the value of Visibility to false, or press Space in the keyboard.
19.2. Select Cut001, click on the Shape Color value to open the Select color dialog, then choose a red color; also change the value of Transparency to 90.

05 T03 Part cube additional cut 1.png

A rotated, hollowed solid, which will be used as a cutting object for some corners of the internal solid.


Ecken abschneiden Teil 2

  1. Wählen Sie "Cube005" und "Cube004" aus, stellen Sie dabei sicher, dass "Cube005" ZUERST ausgewählt wurde
  2. Aktivieren Sie das Menü zum Ändern der Placement-Werte
  3. Wählen Sie die Option Änderungen an Objekt-Placement inkrementell übernehmen aus (beachten Sie, dass alle Werte dabei genullt werden)
  4. Wählen Sie "Rotation: X-Achse" und "Winkel: 45°" aus und klicken Sie auf Anwenden
  5. Wählen Sie "Rotation: Z-Achse" und "Winkel: -45°" aus und klicken Sie auf Anwenden
  6. Klicken Sie auf OK, um den Dialog zu schließen
  7. Erzeugen Sie eine Verschneidung durch Klick auf Part Cut.png, das resultierende Objekt heißt "Cut002"
  8. Klicken Sie auf View-axometric.png, um zur axonometrischen Ansicht zu wechseln
  9. Klicken Sie auf View-zoom-all.png, um auf das ganze Modell zu zoomen

Wenn alles geklappt hat, sieht Ihr Modell nun so aus:

20. In the tree view select Cut001, in the View tab, change the value of Visibility to false, or press Space in the keyboard.

21. In the tree view select Cube004 and Cube005, in the View tab, change the value of Visibility to true, or press Space in the keyboard.

21.1. Open the Placement dialog.
21.2. Tick the option Apply incremental changes; notice that all Translation values are reset to zeroes.
21.3. Change the Rotation to Rotation axis with angle; Axis to X, and Angle to 45 deg, then click on Apply. This will apply a rotation around the X-axis, and will reset the Angle field to zero.
21.4. Change the Rotation again, now Axis to Z, and Angle to -45 deg, then click on Apply. This will apply a rotation around the local Z-axis, and will reset the Angle field to zero.
21.5. Click on OK to close the dialog.

22. In the tree view de-select the objects; then select Cube005 first, the bigger cube, and then Cube004, the smaller cube.

22.1. Then press Part Cut.svg Cut. This will create Cut002. This is a hollowed body which intersects the initial Cut only at certain corners.

23. To visualize this better we can modify the View properties in the property editor.

23.1. Select Cut002, click on the Shape Color value to open the Select color dialog, then choose a pink color; also change the value of Transparency to 90.

06 T03 Part cube additional cut 2.png

Wenn alles gut lief, sollte das Modell wie folgt aussehen:

Das Modell fertig stellen

  1. Wählen Sie "Cut" and "Cut001" aus, stellen Sie dabei sicher, dass "Cut" ZUERST ausgewählt wurde
  2. Erzeugen Sie eine Verschneidung durch Klick auf Part Cut.png, das resultierende Objekt heißt "Cut003"
  3. Wählen Sie "Cut003" und "Cut002" aus, stellen Sie dabei sicher, dass "Cut003" ZUERST ausgewählt wurde
  4. Erzeugen Sie eine Verschneidung durch Klick auf Part Cut.png, das resultierende Objekt heißt "Cut004"
  5. Klicken Sie auf View-axometric.png, um zur axonometrischen Ansicht zu wechseln
  6. Klicken Sie auf View-zoom-all.png, um auf das ganze Modell zu zoomen
  7. Vergessen Sie nicht, die Datei zu speichern ...

24. Make sure all objects are visible. In the tree view select all objects, in the View tab, change the value of Visibility to true, or press Space in the keyboard.

07 T03 Part ball additional both.png

The internal hollowed solid, together with the external objects which will be used to cut it.


25. In the tree view de-select the objects; then select Cut first, and then Cut001.

25.1. Then press Part Cut.svg Cut. This will create Cut003.

08 T03 Part ball cut 1.png

The internal hollowed solid, cut by Cut001.


26. In the tree view de-select the objects; then select Cut003 first, and then Cut002.

26.1. Then press Part Cut.svg Cut. This will create Cut004. This is the final object.
26.2. Select Cut004, click on the Shape Color value to open the Select color dialog, then choose a green color; also change the value of Line Width to 2.0.

09 T03 Part ball cut 2.png

The internal hollowed solid, cut by Cut001 and Cut002. Final model.


27. Real objects don't have perfectly sharp edges or corners, so applying a fillet to the edges can be done to refine the model.

27.1. In the tree view, select Cut004 then press Part Fillet.svg Fillet.
27.2. In the Fillet edges task panel go to Selection, choose Select edges, and then press All. As Fillet type choose Constant radius, then set Radius to 1 mm.
24.3. Press OK. This will create a Fillet object.
27.4. In the View tab, change the value of Line Width to 2.0.

10 T03 Part ball fillet.png

Final whiffle ball model with fillets applied to the edges.


Template:Tutorials navi/de