TechDraw DXF speichern

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page TechDraw SaveDXF and the translation is 93% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский

TechDraw SaveDXF.svg DXF speichern

Menüeintrag
TechDraw → Export page as DXF
Arbeitsbereich
TechDraw
Standardtastenkürzel
None
In der Version eingeführt
0.18
Siehe auch


Beschreibung

Das Werkzeug »DXF speichern« speichert das aktuelle Zeichenblatt als DXF-Datei.

Anwendung

  1. Wählen Sie eine Zeichnung im in der Combo-Box aus, wenn das Dokument mehrere Seiten enthält.
  2. Auf die Schaltfläche TechDraw SaveDXF.png DXF speichern klicken.
  3. Ein Dialogfeld zum Speichern von Dateien wird geöffnet. Wählen Sie einen Speicherort und einen Dateinamen aus.

Einschränkungen

  • Radien und Durchmesser werden nur exportiert, wenn sie sich "innerhalb" des Winkelbogens befinden.
  • Skalierungen werden nicht unterstützt. Die DXF wird in der aktuellen Größe der TechDraw-Zeichnung gezeichnet.
  • Maßeinheiten werden nicht unterstützt. Die DXF wird in Millimeter gezeichnet. Bemaßungen werden so dargestellt wie in der TechDraw-Zeichnung.
  • TechDraw kann keine DraftView oder ArchView nach DXF exportieren. Diese Ansichten sind SVG-Elemente, die intern über die Draft Workbench erstellt wurden. Deshalb sind sie keine geometrischen Gebilde für den Export. Um Ansichten nach DXF zu exportieren, müssen sie mittels TechDraw NewView oder TechDraw NewProjGroup erstellt werden. Als Beispiel, markiere Arch SectionPlane, danach verwende Draft Shape2DView um eine flache Projektion einer Fläche zu erstellen, danach nutze TechDraw NewView für dieses Objekt. Alternativ kann man das Objekt in der Combo-Box oder im 3D-Bauteil markieren und mittels File → Export nach DXF exportieren.
  • Das Schriftfeld der Zeichnung ist eine SVG-Vorlage, die nicht nach DXF exportiert werden kann.
  • Grundsätzlich kann TechDraw nur die Elemete nach DXF exportieren, die unterstützt werden von Import::ImpExpDxfWrite als Bestandteil von Import Module.

Hinweise

  • Diese Funktion exportiert DXF in den Versionen R12 (AC1009) und R14 (AC1014).
    • R12 ist eine ältere, einfachere Version des Standards, sollte aber von den meisten anderen Programmen lesbar sein.
    • R14 ist die Standardversion. Es beinhaltet unter anderem die Unterstützung von Splines.
    • Es gibt zwei Parameter, die die DXF-Ausgabe beeinflussen:
      • Präferenzen → Mod → Import → DxfVersionOut - gültige Einträge sind 12 oder 14. Standard ist 14.
      • Einstellungen → Mod → Import → DiscretizeEllipses - True: Splines/Ellipses sind Polylinien; False: Spline/Ellipses werden als Splines/Ellipsen geschrieben. Standard ist false.
  • Wenn das FreeCAD-Dokument mehrere Seiten enthält, müssen Sie die gewünschte Seite im Feature-Baum auswählen, bevor Sie auf die Export-Schaltfläche klicken.
  • Radiale und diametrale Abmessungen werden nur dann korrekt exportiert, wenn sie sich innerhalb des Bogens befinden.
  • Die Skalierung wird nicht unterstützt. Die DXF-Seite wird in der tatsächlichen Größe der TechDraw-Seite gezeichnet.
  • Einheiten werden nicht unterstützt – das DXF wird in mm gezeichnet. Der Bemaßungstext wird genau so angezeigt, wie in TechDraw.

Programmierung

Siehe auch: TechDraw API und FreeCAD Scripting Basics.

Das Werkzeug »DXF speichern« kann sowohl in Makros als auch aus der Python-Konsole heraus mittels folgender Funktion angesprochen werden:

TechDraw.writeDXFPage(page,filename)