TechDraw Einstellungen

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page TechDraw Preferences and the translation is 10% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎русский
Arrow-left.svg Previous: Hatching
FreeCAD.png

Die Einstellungen für Technisches Zeichnen (TechDraw) befinden sich im Menü Bearbeiten → Einstellungen → TechDraw.

The preferences of the TechDraw Workbench are found in the Preferences Editor, Edit → Preferences → TechDraw.

All preferences settings with italic labels are default values for new drawing objects. They have no effect on existing objects.

TechDraw 1

TechDraw Preferences1.png

  • ProjektionswinkelTechDraw NewProjGroup.png Neue Projektionsgruppe (Mehrseitenansicht) verwendet entweder die erste (europäische Darstellung) oder die dritte (amerikanische Darstellung) Projektionsmethode (siehe auch Normalprojektion [1])
  • Versteckte Linien – der Stil Vollkörper, Bindestrich, Punkt, Strich-Punkt und Strich-Punkt-Punkt werden für versteckte Linien verwendet.
  • Flächen erkennen – wenn diese Option aktiviert ist, versucht TechDraw Liniensegmente von Flächen zu erstellen, die vom Algorithmus als "versteckte Linien" erkannt wurden. Die Flächen werden benötigt, um Techdraw-hatch.png Schraffur anzuwenden. Bei komplexen 3D-Modellen kann es jedoch zu Leistungseinbußen kommen.
  • Schnittkanten zeigen – dazu den Rand der TechDraw NewSection.png Neue Schnittansicht markieren. Normalerweise nur zum Debuggen.
  • Seiten aktuell zu halten – wenn die Zeichnungsseiten in Echtzeit mit dem 3D-Modell synchronisiert werden, können sich die Reaktionszeiten verlangsamen. Bei komplexen 3D-Modellen kann es hilfreich sein, wenn das Kontrollkästchens deaktiviert wird. Um eine einzelne Seite zu aktualisieren, kann die Eigenschaft »KeepUpdated« im Eigenschaftsfenster »Page« verwendet werden.
  • AutoDistribute Secondary Views - Stellt die Standardeinstellung für die automatische Verteilung von Nebenansichten in der Projektgruppe ein.

introduced in version 0.19

  • Update With 3D: Whether or not pages are updated every time the 3D model is changed. This is a global policy setting.
  • Allow Page Override: Whether or not a page's Keep Update property can override the global Update With 3D parameter. This is a global policy setting.
  • Keep Page Up To Date: Keeps drawing pages in sync with changes of the 3D model in real time. This can slow down the response time.
  • Auto-distribute Secondary Views: Automatically distributes secondary views for projection groups.

Farben

Hier können die bevorzugten Farben für verschiedene Darstellungen eingestellt werden.

Kennzeichnungen

  • Label Font: Name des Schriftfonts für die Beschriftung der Ansicht.
  • Label Size: Schriftgröße (mm) für den Beschriftungstext der Ansicht.
  • Template dot size: grüne Einheitspunktgröße in Einheiten

Dateien

  • Standardvorlage: Dateiauswahl, um eine Standardvorlage für die eigenen Zeichnungen zu verwenden.
  • Vorlagen Verzeichnis: Vorlagen-Verzeichnis für TechDraw New Pick.png Neue Vorlagenauswahl.
  • Schraffur-Bild: Standard SVG oder bitmap-Datei für TechDraw Hatch.svg Schraffur.
  • Line Group File - Alternative Datei für persönliche Liniengruppen-Definitionen.
  • PAT-Datei: Standard PAT Schraffurmuster-Datei für TechDraw Hatch.svg Schraffur.
  • Name des Musters: Name des bevorzugten PAT-Schraffurmuster.

Scale

Scale preferences

Scale

  • Page Scale: Default scale for new pages.
  • View Scale Type: Default scale for new views.
  • View Custom Scale: Default scale for views if View Scale Type is Custom.

Selection

  • Edge Fuzz: Size of selection area around edges. The fuzz unit is approximately 0.1 mm, depending on your current zoom.
  • Mark Fuzz: Selection area around center marks. The fuzz unit is approximately 0.1 mm, depending on your current zoom.

Size Adjustments

  • Vertex Scale: Scale of vertex dots. Multiplier of line width.
  • Center Mark Scale: Size of center marks. Multiplier of vertex size.
  • Tolerance Text Scale: Tolerance font size adjustment. Multiplier of dimension Font Size.
  • Template Edit Mark: Size of template field click handles in mm (green dots).

TechDraw 2

preferences tab 2

Bemaßungen

  • Maßeinheiten anzeigen: Fügt die Einheiten (mm, in usw.) hinter der Bemaßung an.
  • Globale Nachkommastellen_Einstellungen verwenden: verwendet die Dezimalstellen aus Einstellungen > Allgemein > Einheiten.
  • Dezimalstellen ändern: wenn »Globale Nachkommastellen-Einstellungen verwenden« deaktiviert ist, werden diese Angaben übernommen.
  • Schriftgröße: Schriftgröße des Bemaßungstextes.
  • Farbe: Standardfarbe für Bemaßungstext und -linie..
  • Durchmesser-Symbol: das Durchmesser-Symbol wird dem Bemaßungstext vorangestellt.
  • Pfeildarstellung: Darstellung der Maßlinienenden auswählen.
  • Pfeilgröße: Größe der Darstellung an den Maßlinienenden in mm.

Dekoration

  • Liniengruppe: Name der Liniengruppen, siehe Liniengruppen.
  • Mattierungsstil: Zeigt TechDraw New Detail.png Neue Detailansicht in einem Kreis oder Rechteck.
  • Linienstil Mittellinie: Linienstil für die Mittellinien (horizontal und vertikal).
  • Farbe der Mittellinie: Farbe für die Mittellinien.
  • Linienstil für Schnitte: Linienstil für Schnitte in der Standardansicht von TechDraw NewSection.png Neue Schnittansicht.
  • Farbe der Schnittlinie: Farbe der Schnittlinien.
  • Schraffurgröße: Liniendicke für TechDraw GeomHatch.svg Geometrische Schraffur. Siehe auch Techdraw-hatch.png Schraffur.
  • Vertex Color: Standardfarbe für Eckpunkte.
  • Vertex Scale: Anpassung der »Knotengröße« auf den Zeichnungen.

Conventions

  • Projection Group Angle: If projection groups will use either first- or third-angle projection. See multiview projection for an explanation.
  • Hidden Line Style: The style to be used for hidden lines.

HLR Parameters

HLR parameters preferences

HLR stands for hidden line removal.

  • Use Polygon Approximation: Uses an approximation to find hidden lines. This is fast, but the result is a collection of short straight lines.
  • Show Hard Lines: Shows hard and outline edges (visible lines always shown)
  • Show Smooth Lines: Shows smooth lines. A smooth line is a line indicating a change between tangent surfaces, as in the transition from a flat surface to a fillet.
  • Show Seam Lines: Show seam lines. A seam line is a boundary between faces.
  • Show UV ISO Lines: Shows ISO lines. ISO stands for isoparametric. Here is a description what isoparametric lines (in fact curves) are.
  • ISO Count: The number of ISO lines per face edge.

Advanced

Advanced preferences
  • Detect Faces: If checked, TechDraw will attempt to build faces using the line segments returned by the hidden line removal algorithm. Faces must be detected in order to use hatching, but there can be a performance penalty in complex models.
  • Show Section Edges: Highlights the border of the section cut in section views.
  • Debug Section: Dumps intermediate results during a Section view processing
  • Debug Detail: Dumps intermediate results during a Detail view processing
  • Allow Crazy Edges: Includes edges with unexpected geometry in results, e.g. zero lengths
  • Fuse Before Section: Performs a fuse operation on the input shape(s) before Section view processing
  • Show Loose 2D Geom: Includes 2D Objects in projections, e.g. loose sketches
  • Line End Cap Shape: Setting of the line end cap shape. Explanation of the options: https://doc.qt.io/qt-5/qt.html#PenCapStyle-enum
  • Max SVG Hatch Tiles: The limit of SVG tiles with a size of 64x64 pixels used to hatch a single face. For large scalings one might get an error about to many SVG tiles, then one needs to increase the tile limit.
  • Max PAT Hatch Segments: The maximum hatch line segments used when hatching a face with a PAT pattern.

Hidden Settings

Note: Since FreeCAD 0.19, all settings are available in the Preferences dialogs. The following only applies for FreeCAD versions older than 0.19:

Some preference settings are only accessible through the Parameter editor, Tools → Edit parameters.

Preferences/Mod/TechDraw/Decorations

  • CenterMarkScale: default scale factor for CenterMarks
  • ShowCenterMarks: default True/False
  • PrintCenterMarks: True/False show CenterMarks when printing introduced in version 0.19

Preferences/Mod/TechDraw/General

  • DefaultScale: initial setting of Page Scale introduced in version 0.19
  • EdgeFuzz: pick radius for Edges
  • MarkFuzz: pick radius for CenterMarks
  • SectionFuseFirst: fuse Source objects before performing Section cut
  • EdgeEndCap: shape of Edge ends 0x00 FlatCap, 0x10 SquareCap, 0x20 RoundCap (Qt::PenCapStyle) introduced in version 0.19

Preferences/Mod/TechDraw/Format

  • SectionFormat: section line style 0-ASME 1-ISO

Preferences/Mod/TechDraw/Standards

  • RadiusAligned: Radius dimension format 0-ISO(aligned) 1-ASME(uniform)
Arrow-left.svg Previous: Hatching
FreeCAD.png