TechDraw Exporter au format DXF

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page TechDraw ExportPageDXF and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano
Arrow-left.svg Page précédente : TechDraw ExportPageSVG.svg Exporter au format SVG
Page suivante : Hachures par motifs TechDraw Hatch.svg Arrow-right.svg

TechDraw ExportPageDXF.svg TechDraw Exporter au format DXF

Emplacement du menu
TechDraw → Exporter une page au format DXF
Ateliers
TechDraw
Raccourci par défaut
Aucun
Introduit dans la version
0.19
Voir aussi
TechDraw Exporter au format SVG, Draft DXF


Description

L'outil Exporter la page en Dxf enregistre une page de dessin en un fichier au format DXF

Utilisation

  1. Sélectionnez une page dans l'arborescence si le document contient plusieurs pages.
  2. Cliquer sur le bouton TechDraw ExportPageDXF.svg Export Page as DXF
  3. Sélectionnez un emplacement et un nom de fichier.

Limitations

  • Les dimensions radiales et de diamètre ne s'exporteront correctement que si elles sont "à l'intérieur" de l'arc.
  • La mise à l'échelle n'est pas prise en charge. Le DXF sera dessiné dans la taille réelle de la page TechDraw.
  • Les unités ne sont pas prises en charge. Le DXF sera dessiné en millimètres (mm). Le texte de cote sera affiché exactement tel qu'il est affiché dans TechDraw.
  • TechDraw ne peut pas exporter un TechDraw Vue Draft ou une TechDraw Vue architecturale vers DXF. Ces vues sont des éléments SVG générés en interne par l'atelier Draft, il n'y a donc pas de forme géométrique à exporter. Pour exporter une vue au format DXF, elle doit avoir été créée avec TechDraw Vue ou TechDraw Projection de groupe. Par exemple, sélectionnez un Arch Plan de section, puis utilisez Draft Projection 2D d'une forme pour créer une forme de projection plate, puis utilisez TechDraw Vue sur cet objet. Vous pouvez également sélectionner les objets dans l'arborescence ou la fenêtre 3D et exporter vers DXF à l'aide de Fichier → Export.
  • Le cartouche d'une page est également un modèle SVG, il ne sera donc pas non plus exporté vers DXF.
  • En général, TechDraw ne peut exporter vers DXF que les éléments pris en charge par la classe Import::ImpExpDxfWrite du Module d'importation.

Remarques

  • Cette fonction exporte les versions R12 (AC1009) et R14 (AC1014) de DXF.
    • R12 est une version plus ancienne et plus simple de la norme mais devrait être lisible par la plupart des autres logiciels.
    • R14 est la version par défaut. Elle inclut entre autres la prise en charge des splines et des ellipses.
  • Ces paramètres affectent la sortie:
    • Outils → Editer paramètres → BaseApp/Preferences/Mod/Import → DxfVersionOut. Il s'agit d'une valeur entière. Les entrées valides sont 12 ou 14. La valeur par défaut est 14.
    • Outils → Editer paramètres → BaseApp/Preferences/Mod/Import → DiscretizeEllipses. Il s'agit d'une valeur booléenne. Si true, les splines et les ellipses sont converties en polylignes; si false, les splines et les ellipses sont écrites en tant qu'objets splines et ellipses. Par défaut false. Si le paramètre DxfVersionOut est 12, les splines et les ellipses sont toujours converties en polylignes.
    • Outils → Editer paramètres → BaseApp/Preferences/Mod/Import → maxsegmentlength. Il s'agit d'une valeur flottante. Si les splines et les ellipses sont converties en polylignes, ce paramètre détermine la longueur du segment.

Script

Voir aussi : TechDraw API et FreeCAD Scripts de base.

L'outil Sauvegarder en DXF peut être utilisé dans des macros et à partir de la console Python à l'aide des fonctions suivantes:

TechDraw.writeDXFPage(page,filename)
Arrow-left.svg Page précédente : TechDraw ExportPageSVG.svg Exporter au format SVG
Page suivante : Hachures par motifs TechDraw Hatch.svg Arrow-right.svg