TechDraw ExportSeiteDXF

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page TechDraw ExportPageDXF and the translation is 87% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

TechDraw ExportPageDXF.svg TechDraw ExportSeiteDXF

Menüeintrag
TechDraw → Exportiere Seite als DXF
Arbeitsbereich
TechDraw
Standardtastenkürzel
Keiner
Eingeführt in Version
0.18
Siehe auch
TechDraw Exportiere Seite als SVG, Entwurf DXF

Beschreibung

Das ExportSeiteDXF Werkzeug speichert eine Zeichnungsseite als DXF Datei.

Anwendung

  1. Wähle eine Seite in der Baumansicht, wenn das Dokument mehrere Seiten enthält.
  2. Drücke die TechDraw ExportPageDXF.svg Exportiere Seite als DXF Schaltfläche.
  3. Wähle einen Speicherort und einen Dateinamen.

Begrenzungen

  • Radien und Durchmesserbemaßungen werden nur dann korrekt exportiert, wenn sie "innerhalb" des Bogens liegen.
  • Skalierung wird nicht unterstützt. Das DXF wird in der tatsächlichen Größe der TechDraw Seite gezeichnet.
  • Einheiten werden nicht unterstützt. Das DXF wird in Millimetern (mm) gezeichnet. Bemaßungstext wird genau wie in TechDraw angezeigt.
  • TechDraw kann keine Einfügen eines Entwurf Arbeitsbereichsobjekts oder ein Einfügen eines Arch Arbeitsbereichsobjekt zu DXF exportieren. Diese Ansichten sind SVG Elemente, die intern vom Entwurf Arbeitsbereich generiert werden, so dass es keine geometrische Form zum Exportieren gibt. Um eine Ansicht als DXF zu exportieren, muss sie mit Ansicht einfügen oder Projektionsgruppe einfügen erstellt worden sein. Wähle z. B. eine Arch SchnittEbene, dann verwende Entwurf Form2DAnsicht um eine flache Projektionsform zu erstellen, und verwende dann Ansicht einfügen für dieses Objekt. Alternativ wähle die Objekte in der Baumansicht oder im 3D Ansichtsfenster aus und exportiere sie mit Datei → Export.
  • Der Titelblock einer Seite ist ebenfalls eine SVG Vorlage, daher wird er auch nicht nach DXF exportiert.
  • Im Allgemeinen kann TechDraw nur die Elemente nach DXF exportieren, die von der Import::ImpExpDxfWrite Klasse des Import Moduls.

Hinweise

  • Diese Funktion exportiert die Versionen R12 (AC1009) und R14 (AC1014) von DXF.
    • R12 ist eine ältere, einfachere Version des Standards, sollte aber für die meisten anderen Programme lesbar sein.
    • R14 ist die Standardversion. Sie enthält unter anderem Unterstützung für Splines und Ellipsen.
  • Diese Parameter beeinflussen die Ausgabe:
    • Werkzeuge → Parameter Berabeiten → BasisApp/Einstellungen/Mod/Import → DxfVersionOut. Dies ist ein ganzzahliger Wert. Gültige Einträge sind 12 oder 14. Der Standardwert ist 14.
    • Werkzeuge → Parameter Berabeiten → BasisApp/Einstellungen/Mod/Import → DiscretizeEllipses. Dies ist ein boolescher Wert. Wenn true, werden Splines und Ellipsen in Polylinien umgewandelt; wenn false, werden Splines und Ellipsen als Splines- und Ellipsenobjekte geschrieben. Die Vorgabe ist false. Wenn der Parameter DxfVersionOut 12 ist, werden Splines und Ellipsen immer in Polylinien konvertiert.
    • Werkzeuge → Parameter Berabeiten → BasisApp/Einstellungen/Mod/Import → maxsegmentlength. Dies ist ein Gleitkommawert. Wenn Splines und Ellipsen in Polylinien umgewandelt werden, bestimmt dieser Parameter die Segmentlänge.

Skripten

Siehe auch: TechDrawGui API und FreeCAD Grundlagen Skripten.

Das SpeichereDXF Werkzeug kann in Makros und aus der Python Konsole mit den folgenden Funktionen benutzt werden:

TechDraw.writeDXFPage(page,filename)