TechDraw ExportPageDXF

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano

TechDraw ExportPageDXF.svg TechDraw ExportPageDXF

Menu location
TechDraw → Export Page as DXF
Workbenches
TechDraw
Default shortcut
None
Introduced in version
0.18
See also
Export Page as SVG, Draft DXF


Description

The ExportPageDXF tool saves a drawing page as a DXF file.

Usage

  1. Select a Page in the tree view, if the document contains multiple pages.
  2. Press the TechDraw ExportPageDXF.svg Export Page as DXF button.
  3. Select a location and file name.

Limitations

  • Radial and Diameter dimensions will only export properly if they are "inside" the arc.
  • Scaling is not supported. The DXF will be drawn in the actual size of the TechDraw page.
  • Units are not supported. The DXF will be drawn in millimeters (mm). Dimension text will be shown exactly as displayed in TechDraw.
  • TechDraw can't export a Insert Draft Workbench Object or an Insert Arch Workbench Object to DXF. These views are SVG elements generated internally by the Draft Workbench, so there is no geometrical shape to export. To export a view as DXF, it must have been created with Insert View or Insert Projection Group. For example, select an Arch SectionPlane, then use Draft Shape2DView to create a flat projection shape, and then use Insert View on this object. Alternatively, select the objects from the tree view or the 3D viewport, and export to DXF using File → Export.
  • The title block of a page is an SVG template as well, so it will not be exported to DXF either.
  • In general, TechDraw can only export to DXF those elements that are supported by the Import::ImpExpDxfWrite class of the Import Module.

Notes

  • This function exports the R12 (AC1009) and R14 (AC1014) versions of DXF.
    • R12 is an older, simpler version of the standard, but should be readable by most other software.
    • R14 is the default version. It includes support for splines and ellipses among other things.
  • These parameters affect the output:
    • Tools → Edit parameters → BaseApp/Preferences/Mod/Import → DxfVersionOut. This is an integer value. Valid entries are 12 or 14. The default is 14.
    • Tools → Edit parameters → BaseApp/Preferences/Mod/Import → DiscretizeEllipses. This is a boolean value. If True, splines and ellipses are converted to polylines; if False, splines and ellipses are written as splines and ellipses objects. The default is False. If the DxfVersionOut parameter is 12, splines and ellipses are always converted to polylines.
    • Tools → Edit parameters → BaseApp/Preferences/Mod/Import → maxsegmentlength. This is a float value. If splines and ellipses are converted to polylines this parameter determines the segment length.

Scripting

See also: TechDrawGui API and FreeCAD Scripting Basics.

The SaveDXF tool can be used in macros and from the Python console by using the following functions:

TechDraw.writeDXFPage(page,filename)