Std: Środowisko pracy

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std Workbench and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский

Std Środowiska pracy

Lokalizacja w menu
Widok → Środowiska pracy
Środowisko pracy
Środowiska pracy
Domyślny skrót
brak
Wprowadzono w wersji
-
Zobacz także
brak

Opis

Polecenie Środowiska pracy aktywuje wybrane Środowisko pracy wraz z jego graficznym interfejsem użytkownika (GUI).

FreeCAD interface base divisions.svg

Menu rozwijane dla środowisk pracy oznaczone numerem 10 w standardowym interfejsie.

Użycie

  1. Istnieje kilka sposobów na wywołanie polecenia:
    • Wybierz środowisko pracy z rozwijanej listy środowisk pracy na pasku narzędziowym środowiska. Opcja ta nie jest dostępna, jeśli bieżącym środowiskiem roboczym jest <none>. (brak środowiska pracy).
    • Wybierz środowisko pracy z menu podrzędnego Widok → Środowiska pracy.

Uwagi

Ustawienia

  • Rozruchowy warsztat pracy można zmienić w preferencjach: Edycja → Preferenceje → Ogólne → Ogólne → Uruchamianie. Zobacz też Edytor ustawień.

Tworzenie skryptów

Zobacz również: FreeCAD podstawy tworzenia skryptów.

Aby zmienić środowisko pracy należy użyć metody activateWorkbench modułu FreeCADGui. Metoda ta nie jest dostępna, jeśli FreeCAD jest uruchomiony w trybie konsoli.

import FreeCADGui

FreeCADGui.activateWorkbench("PartDesignWorkbench")