Std ViewZoomOut

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Std ViewZoomOut.svg Std ViewZoomOut

Menu location
View → Zoom → Zoom Out
Workbenches
All
Default shortcut
Ctrl+-
Introduced in version
-
See also
Std ViewZoomIn, Std ViewBoxZoom


Description

The Std ViewZoomOut command zooms out in the active 3D view.

Usage

  1. There are several ways to invoke the command:
    • Select the View → Zoom → Std ViewZoomOut.svg Zoom Out option from the menu.
    • Use the keyboard shortcut: Ctrl+-.

Notes

  • It is also possible to zoom with the mouse scroll wheel.

Preferences

  • The zoom factor can be changed in the preferences: Edit → Preferences... → Display → Navigation → Zoom step. This setting also affects scroll wheel zoom. See Preferences Editor.

Scripting

See also: FreeCAD Scripting Basics.

To zoom out use the zoomOut method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.zoomOut()