Команда "Стерео красный/голубой"

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std ViewIvStereoRedGreen and the translation is 69% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Std ViewIvStereoRedGreen.svg Std ViewIvStereoRedGreen

Системное название
Std ViewIvStereoRedGreen
Расположение в меню
Вид → Стерео → Стерео красный/голубой
Верстаки
All
Быстрые клавиши
Нет
Представлено в версии
-
См. также
Std ViewIvStereoQuadBuff, Std ViewIvStereoInterleavedRows, Std ViewIvStereoInterleavedColumns, Std ViewIvStereoOff

Описание

The Std ViewIvStereoRedGreen command changes the active 3D view to red/cyan, anaglyph, stereo view mode. To use this stereo mode glasses with colored lenses are requires.

Применение

  1. Select the View → Stereo → Std ViewIvStereoRedGreen.svg Stereo red/cyan option from the menu.

Настройки

  • Расстояние между глаз может быть изменено в настройках: Правка → Настройки... → Отображение → Трёхмерный вид → Расстояние между глаз для стерео режима. Смотри Редактор настроек.

Scripting

Смотрите так же: Основы составления скриптов в FreeCAD.

To change the view to red/cyan stereo use the setStereoType method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setStereoType('Anaglyph')
FreeCADGui.ActiveDocument.ActiveView.getStereoType()