Команда "Стерео с чередованием строк"

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std ViewIvStereoInterleavedRows and the translation is 69% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Std ViewIvStereoInterleavedRows.svg Std ViewIvStereoInterleavedRows

Системное название
Std ViewIvStereoInterleavedRows
Расположение в меню
Вид → Стерео → View → Стерео с чередованием строк
Верстаки
All
Быстрые клавиши
Нет
Представлено в версии
-
См. также
Std ViewIvStereoRedGreen, Std ViewIvStereoQuadBuff, Std ViewIvStereoInterleavedColumns, Std ViewIvStereoOff

Описание

The Std ViewIvStereoInterleavedRows command changes the active 3D view to interleaved rows stereo view mode. To use this stereo mode a special graphics card, a special display and glasses with polarized lenses are requires.

Применение

  1. Select the View → Stereo → Std ViewIvStereoInterleavedRows.svg Stereo interleaved Rows option from the menu.

Настройки

  • Расстояние между глаз может быть изменено в настройках: Правка → Настройки... → Отображение → Трёхмерный вид → Расстояние между глаз для стерео режима. Смотри Редактор настроек.

Scripting

Смотрите так же: Основы составления скриптов в FreeCAD.

To change the view to interleaved rows stereo use the setStereoType method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setStereoType('InterleavedRows')
FreeCADGui.ActiveDocument.ActiveView.getStereoType()