Std Lignes stéréo entrelacées

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std ViewIvStereoInterleavedRows and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Std ViewIvStereoInterleavedRows.svg Std Lignes stéréo entrelacées

Emplacement du menu
Affichage → Stéréo → Lignes stéréo entrelacées
Ateliers
Tous
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Std Stéréo rouge cyan, Std Tampon stéréo quadruple, Std Colonnes stéréo entrelacées, Std Stéréo désactivée

Description

La commande Std Lignes stéréo entrelacées change le mode actif de la vue 3D en mode d'affichage stéréo des lignes entrelacées. Pour utiliser ce mode stéréo, une carte graphique spéciale, un écran spécial et des lunettes avec verres polarisés sont nécessaires.

Utilisation

  1. Sélectionnez l'option Affichage → Stéréo → Std ViewIvStereoInterleavedRows.svg Lignes stéréo entrelacées dans le menu.

Préférences

  • La distance entre les yeux peut être modifiée dans les préférences: Édition → Préférences... → Affichage → Vue 3D → Eye to eye distance for stereo modes. Voir l'Editeur de préférences.

Script

Voir aussi: FreeCAD Script de base.

Pour modifier la vue en lignes entrelacées stéréo, utilisez la méthode setStereoType de l'objet ActiveView. Cette méthode n'est pas disponible si FreeCAD est en mode console.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setStereoType('InterleavedRows')
FreeCADGui.ActiveDocument.ActiveView.getStereoType()