Std AnsichtIvStereoÜberlappteZeilen

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std ViewIvStereoInterleavedRows and the translation is 23% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Std ViewIvStereoInterleavedRows.svg Std ViewIvStereoInterleavedRows

Menu location
View → Stereo → Stereo interleaved Rows
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
Std ViewIvStereoRedGreen, Std ViewIvStereoQuadBuff, Std ViewIvStereoInterleavedColumns, Std ViewIvStereoOff

Beschreibung

The Std ViewIvStereoInterleavedRows command changes the active 3D view to interleaved rows stereo view mode. To use this stereo mode a special graphics card, a special display and glasses with polarized lenses are requires.

Anwendung

  1. Select the View → Stereo → Std ViewIvStereoInterleavedRows.svg Stereo interleaved Rows option from the menu.

Preferences

  • The eye to eye distance can be changed in the preferences: Edit → Preferences... → Display → 3D View → Eye to eye distance for stereo modes. See Preferences Editor.

Scripting

See also: FreeCAD Scripting Basics.

To change the view to interleaved rows stereo use the setStereoType method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setStereoType('InterleavedRows')
FreeCADGui.ActiveDocument.ActiveView.getStereoType()