Std ViewIvStereoInterleavedColumns

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
English • ‎français • ‎italiano • ‎русский

Std ViewIvStereoInterleavedColumns.svg Std ViewIvStereoInterleavedColumns

Menu location
View → Stereo → Stereo interleaved Columns
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
Std ViewIvStereoRedGreen, Std ViewIvStereoQuadBuff, Std ViewIvStereoInterleavedRows, Std ViewIvStereoOff

Description

The Std ViewIvStereoInterleavedColumns command changes the active 3D view to interleaved columns stereo view mode. To use this stereo mode a special graphics card, a special display and glasses with polarized lenses are requires.

Usage

  1. Select the View → Stereo → Std ViewIvStereoInterleavedColumns.svg Stereo interleaved Columns option from the menu.

Preferences

  • The eye to eye distance can be changed in the preferences: Edit → Preferences... → Display → 3D View → Eye to eye distance for stereo modes. See Preferences Editor.

Scripting

See also: FreeCAD Scripting Basics.

To change the view to interleaved columns stereo use the setStereoType method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setStereoType('InterleavedColumns')
FreeCADGui.ActiveDocument.ActiveView.getStereoType()