Std BenutzerBearbeitungsModus

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std UserEditMode and the translation is 96% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎polski

Std UserEditMode.svg Std BenutzerBearbeitungsmodus

Menüeintrag
Bearbeiten → Bearbeitungsmodus → ...
Arbeitsbereich
Alle
Standardtastenkürzel
Keiner
Eingeführt in Version
0.20
Siehe auch
Std Berbeiten

Beschreibung

Die Anweisung Std BenutzerBearbeitungsmodus legt den Bearbeitungsmodus fest, der verwendet wird, wenn ein Objekt mit einem Doppelklick in der Baumansicht gewählt wird.

Anwendung

  1. Es gibt mehrere Wege, die Anweisung zu geben:
    • Auf den schwarzen Pfeil rechts neben der Schaltfläche Std UserEditModeDefault.svg Std BenutzerBearbeitungsmodus klicken und einen Bearbeitungsmodus aus dem Ausklappmenü wählen. Beachte: das Bildchen der Schaltfläche ändert sich gemäß der gewählen Möglichkeit.
    • Unter dem Menüpunkt Ansicht → Navigations/Editier-Modus einen Bearbeitungsmodus wählen.

mögliche Bearbeitungsmodi

Std UserEditModeDefault.svg Vorgabe

Das Objekt wird mit seinem vorgegebenen Bearbeitungsmodus bearbeitet. Dieser Bearbeitungsmodus wird intern mit dem am besten passend für den Objekttyp festgelegt, z.B. wird dies die Formeigenschaftsbearbeitung für Part Grundelemente und PartDesign Formelemente sein, die Positionierungsbearbeitung für Part Boolesche Operationen etc.

Std UserEditModeTransform.svg Transformieren

Die Positionierung eines Objektes is mit der Anweisung Std Transformieren bearbeitbar.

Std UserEditModeCutting.svg Abtrennen

Dieser Bearbeitungsmodus ist verwendbar, scheint aber durch kein Objekt verwendet zu werden.

Std UserEditModeColor.svg Farbe

Mit der Anweisung Part Flächenfarben kann die Farbe für jede einzelne Oberfläche des Objektes bestimmt werden.

Hinweise

Nicht jedes Objekt kann durch alle Bearbeitungsmodi bearbeitet werden. Ist ein Bearbeitunsmodus für ein Objekt nicht zutreffend, wird stattdessen der vorgegebene Bearbeitungsmodus verwendet.

Einstellungen

  • Der letzte Bearbeitungsmodus wird gespeichert: Werkzeuge → Parameter bearbeiten... → BaseApp → Preferences → General → UserEditMode

Skripten

Siehe auch: FreeCAD Grundlagen Skripten.

Um mögliche Bearbeitungsmodi anzuzeigen:

import FreeCADGui
FreeCADGui.listUserEditModes()

Um den aktiven Bearbeitungsmodus zu erhalten:

import FreeCADGui
FreeCADGui.getUserEditMode()

Um den aktiven Bearbeitungsmodus zu einzustellen:

import FreeCADGui
FreeCADGui.setUserEditMode(MODENAME) # Where MODENAME is a string available in the list of edit modes