Std: Jeden dokument w widoku drzewa

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std TreeSingleDocument and the translation is 9% complete.
Other languages:
English • ‎français • ‎italiano • ‎polski • ‎русский

Std TreeSingleDocument.svg Std TreeSingleDocument

Menu location
View → TreeView actions → Single document
Workbenches
All
Default shortcut
None
Introduced in version
0.19
See also
Std TreeMultiDocument, Std TreeCollapseDocument

Description

The Std TreeSingleDocument command switches the Tree view DocumentMode to SingleDocument. In this mode only a single document is visible in the Tree view. The other modes are MultiDocument and CollapseDocument.

In SingleDocument mode you can switch to a different document by activating a 3D view belonging to that document. You can do this in the Main view area or via the Windows menu.

Usage

  1. There are several ways to invoke the command:
    • Click on the black down arrow to the right of the Std TreeSyncView.svg button and select the Single document option from the flyout. Note: the button image will change depending on the selected option.
    • Select the View → TreeView actions → Std TreeSingleDocument.svg Single document option from the menu.

Preferences

The Tree view DocumentMode mode is stored: Tools → Edit parameters... → BaseApp → Preferences → TreeView → DocumentMode. It is an integer value. Possible values are 0 (SingleDocument), 1 (MultiDocument) or 2 (CollapseDocument). The default is 2.