Std Arborescence Document unique

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std TreeSingleDocument and the translation is 100% complete.
Other languages:
English • ‎français • ‎italiano • ‎русский

Std TreeSingleDocument.svg Std Arborescence Document unique

Emplacement du menu
Affichage → Configuration de l'arborescence → Document unique
Ateliers
Tous
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Std Arborescence Document multiple, Std Arborescence Réduire développer


Description

La commande Std Document unique bascule la vue en arborescence du mode Document (DocumentMode) au mode Document unique (SingleDocument). Dans ce mode, un seul document est visible dans l'arborescence. Les autres modes sont Arborescence Document multiple et Arborescence Réduire développer.

En mode Document unique, vous pouvez basculer vers un autre document en activant une vue 3D appartenant à ce document. Vous pouvez le faire dans Zone de vue principale ou via le menu Fenêtre .

Utilisation

  1. Il existe plusieurs façons d'appeler la commande:
    • Cliquez sur la flèche noire vers le bas à droite du bouton Std TreeSyncView.svg et sélectionnez l'option Single document dans le menu déroulant. Remarque: l'image du bouton changera en fonction de l'option sélectionnée.
    • Sélectionnez l'option Affichage → Configuration de l'arborescence → Std TreeSingleDocument.svg Document unique dans le menu.

Préférences

Le mode de l'arborescence est enregistré: Outils → Editer paramètres... → BaseApp → Preferences → TreeView → DocumentMode. Il s'agit d'une valeur entière. Les valeurs possibles sont 0 (SingleDocument- un seul document), 1 (MultiDocument - plusieurs documents) ou 2 (CollapseDocument - Réduire les documents). La valeur par défaut est 2.