Std TreeRecordSelection

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
English • ‎français • ‎italiano • ‎русский

Std TreeRecordSelection.svg Std TreeRecordSelection

Menu location
View → TreeView actions → Record selection
Workbenches
All
Default shortcut
T 5
Introduced in version
-
See also
None


Description

The Std TreeRecordSelection command toggles the Tree view RecordSelection mode. If this mode is on, each Tree view selection is stored for future use. With the Std SelBack.svg and Std SelForward.svg buttons you can go backwards and forwards through these selections and restore them.

Usage

  1. There are several ways to invoke the command:
    • Click on the black down arrow to the right of the Std TreeSyncView.svg button and select the Record selection option from the flyout. Note: the button image will change depending on the selected option.
    • Select the View → TreeView actions → Std TreeRecordSelection.svg Record selection option from the menu.
    • Use the keyboard shortcut: T then 5.

Preferences

The Tree view RecordSelection mode is stored: Tools → Edit parameters... → BaseApp → Preferences → TreeView → RecordSelection. It is a boolean value, the default is true.