Std TreePreSelection

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
English • ‎français • ‎italiano • ‎русский

Std TreePreSelection.svg Std TreePreSelection

Menu location
View → TreeView actions → Pre-selection
Workbenches
All
Default shortcut
T 4
Introduced in version
-
See also
None


Description

The Std TreePreSelection command toggles the Tree view PreSelection mode. If this mode is on, an object that the mouse is over in the Tree view will be pre-selectected (temporarily highlighted) in all 3D views belonging to that object's document.

Usage

  1. There are several ways to invoke the command:
    • Click on the black down arrow to the right of the Std TreeSyncView.svg button and select the Pre-selection option from the flyout. Note: the button image will change depending on the selected option.
    • Select the View → TreeView actions → Std TreeSyncView.svg Pre-selection option from the menu.
    • Use the keyboard shortcut: T then 4.

Preferences

The Tree view PreSelection mode is stored: Tools → Edit parameters... → BaseApp → Preferences → TreeView → PreSelection. It is a boolean value, the default is true.