Std TreeMultiDocument

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
English • ‎français • ‎italiano • ‎русский

Std TreeMultiDocument.svg Std TreeMultiDocument

Menu location
View → TreeView actions → Multi document
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
Std TreeSingleDocument, Std TreeCollapseDocument


Description

The Std TreeMultiDocument command switches the Tree view DocumentMode to MultiDocument. In this mode all documents are visible in the Tree view and multiple documents can be expanded. The other modes are SingleDocument and CollapseDocument.

Usage

  1. There are several ways to invoke the command:
    • Click on the black down arrow to the right of the Std TreeSyncView.svg button and select the Multi document option from the flyout. Note: the button image will change depending on the selected option.
    • Select the View → TreeView actions → Std TreeMultiDocument.svg Multi document option from the menu.

Preferences

The Tree view DocumentMode mode is stored: Tools → Edit parameters... → BaseApp → Preferences → TreeView → DocumentMode. It is an integer value. Possible values are 0 (SingleDocument), 1 (MultiDocument) or 2 (CollapseDocument). The default is 2.