Std TreeCollapseDocument

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
English • ‎français • ‎italiano • ‎русский

Std TreeCollapseDocument.svg Std TreeCollapseDocument

Menu location
View → TreeView actions → Collapse/Expand
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
Std TreeSingleDocument, Std TreeMultiDocument


Description

The Std TreeCollapseDocument command switches the Tree view DocumentMode to CollapseDocument. In this mode activating a document’s 3D view will automatically expand that document in the Tree view and collapse all other documents. The other modes are SingleDocument and MultiDocument.

Usage

  1. There are several ways to invoke the command:
    • Click on the black down arrow to the right of the Std TreeSyncView.svg button and select the Collapse/Expand option from the flyout. Note: the button image will change depending on the selected option.
    • Select the View → TreeView actions → Std TreeCollapseDocument.svg Collapse/Expand option from the menu.

Preferences

The Tree view DocumentMode mode is stored: Tools → Edit parameters... → BaseApp → Preferences → TreeView → DocumentMode. It is an integer value. Possible values are 0 (SingleDocument), 1 (MultiDocument) or 2 (CollapseDocument). The default is 2.