Std NavigationEditieren

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std ToggleNavigation and the translation is 90% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎русский

Std ToggleNavigation.svg Std NavigationEditieren

Menüeintrag
Ansicht → Navigations/Editier-Modus
Arbeitsbereich
All
Standardtastenkürzel
Esc
Eingeführt in Version
-
Siehe auch
Keiner

Beschreibung

Der Befehl Std NavigationEditieren ist für bestimmte Untersuchungstätigkeiten und bestimmte interaktive Netzbearbeitungen gedacht. Diese Tätigkeiten sind rechchenintensiv und erfordern einen Editiermodus der Navigationmöglichkeiten weitestgehend deaktiviert. Mit diesem Befehl ist es möglich, zeitweilig vom Editiermodus zum Navigationsmodus umzuschalten und nach Änderung der 3D-Ansicht wieder zurück zum Editiermodus.

Nicht mit dem Befehl Std Bearbeiten verwechseln.

Anwendung

Ein Beispiel zur Anwendung des Befehls:

  1. Switch to the Workbench Mesh.svg Mesh Workbench.
  2. Select the Meshes → Mesh BuildRegularSolid.svg Regular solid... option from the menu.
  3. The Regular Solid dialog box opens.
  4. Choose Ellipsoid from the dropdown list.
  5. Press the Create button.
  6. Press the Close button to close the dialog box.
  7. Select the mesh object.
  8. Press the Mesh PolyCut.svg Mesh PolyCut button.
  9. Pick points in the 3D view to define a polygon that overlaps one half of the mesh.
  10. Right-click and choose Inner from the context menu.
  11. The result is an open mesh with a boundary.
  12. Make sure the mesh is still selected.
  13. Select the Meshes → Mesh AddFacet.svg Add triangle option from the menu to invoke the Mesh AddFacet command.
  14. If you hover over a boundary point a yellow marker will appear and a left-click will select it.
  15. Optionally select two more points and add a triangle to the mesh.
  16. You are now in edit mode and it is impossible to rotate or pan the 3D view, although zooming still works.
  17. Invoke the Std ToggleNavigation command to switch to navigation mode:
    • Select the View → Std ToggleNavigation.svg Toggle navigation/Edit mode option from the menu.
    • Or use the keyboard shortcut: Esc.
  18. Now you can rotate and pan the 3D view, but you cannot pick points to add triangles.
  19. Invoke the Std ToggleNavigation command to switch back to edit mode:
    • Select the View → Std ToggleNavigation.svg Toggle navigation/Edit mode option from the menu.
    • Or use the keyboard shortcut: Esc.
  20. You can again pick points and add triangles.
  21. Right-click in the 3D view and choose Finish from the context menu to end the Mesh AddFacet command.