Std SaveaCopy

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std SaveaCopy and the translation is 7% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Std SaveaCopy.png Std SaveaCopy

poziția meniului
File → Save a Copy...
Workbenches
All
scurtătură
C
Prezentat în versiune
-
A se vedea, de asemenea,
Save, Save as...


Descriere

Salvați o copie a documentului sub un nou nume de fișier.

The Std SaveCopy command saves a copy of the active document under a new file name.

Use

Alegeți File Save a Copy... din meniul principal.

  1. Select the File → Save a Copy... option from the menu.
  2. Enter a filename in the dialog box.
  3. Press the Save button.

Options

  • Press Esc or the Cancel button to abort the command.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To save a copy of a document use the saveCopy method of the document object.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'testCopy.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveCopy(fnm)

Template:Std Base navi/ro