File: Salva una copia

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std SaveaCopy and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Std SaveAs.svg Salva con nome Pagina precedente:
Pagina successiva: Salva tutto Arrow-right.svg

Salva una copia

Nome nel codice
Std_SaveCopy
Posizione nel menu
File → Salva una copia...
Ambiente
All
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Salva con nome, Salva


Descrizione

Il comando Salva una copia salva una copia del documento attivo con un nuovo nome di file.

Utilizzo

  1. Selezionare File → Salva una copia... nel menu.
  2. Immettere un nome per il file nella finestra di dialogo.
  3. Premere il pulsante Salva.

Opzioni

  • Premere il tasto Esc o il pulsante Annulla per annullare il comando.

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Vedere anche: Script di base per FreeCAD

Per salvare una copia di un documento, utilizzare il metodo saveCopy dell'oggetto documento.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'testCopy.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveCopy(fnm)
Arrow-left.svg Std SaveAs.svg Salva con nome Pagina precedente:
Pagina successiva: Salva tutto Arrow-right.svg