Команда "Сохранить копию..."

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std SaveCopy and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎한국어

Std SaveCopy.svg Сохранить копию...

Системное название
Std_SaveCopy
Расположение в меню
Файл → Сохранить копию...
Верстаки
Все
Быстрые клавиши
Нет
Представлено в версии
-
См. также
Сохранить,
Сохранить как...

Описание

Команда Сохранить копию... сохраняет копию активного документа под новым названием.

Применение

  1. Выберите пункт главного меню Файл → Std SaveCopy.svg Сохранить копию....
  2. Введите имя файла в появившемся окне.
  3. Нажмите кнопку Сохранить.

Опции

  • Нажмите Esc или кнопку Отмена, чтобы прервать выполнение команды.

Настройки

  • Путь к последнему файлу к которому была применена данная команда сохраняется в параметр: Инструменты → Редактор параметров... → BaseApp → Preferences → General → FileOpenSavePath.

Программирование

Смотрите так же: Основы составления скриптов в FreeCAD.

Для сохранения копии документа используйте метод saveCopy объекта document.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'testCopy.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveCopy(fnm)