File: Salva con nome

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std SaveAs and the translation is 59% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Std Save.svg Salva Pagina precedente:
Pagina successiva: Salva una copia Arrow-right.svg

Std SaveAs.svg Salva con nome

Nome nel codice
Std SaveAs
Posizione nel menu
File → Salva con nome...
Ambiente
Tutti
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Salva una copia, Salva


Descrizione

The Std SaveAs command saves the active document under a new file name.

Utilizzo

Scegliere File → Std SaveAs.png Salva con nome... dal menu principale.

Il comando Salva con nome... permette di salvare il documento attivo del progetto in corso.

Apre una finestra per definire il percorso e il nome:

FileSaveAs.png

Salva i documenti del progetto in file distinti. Se nel progetto esistono altri documenti questi non vengono salvati. Il nome assegnato al documento per salvarlo diventa anche il nome utilizzato per la radice di quel documento nell'albero della struttura. Nei salvataggi successivi, se eseguiti con Salva, vengono automaticamente utilizzati il percorso e il nome definiti per il primo salvataggio. Per salvare il file in una posizione diversa o attribuire ad esso un nuovo nome occorre riutilizzare il comando Salva con nome....


Quando si tenta di chiudere un documento non salvato, o modificato, o di uscire da FreeCAD con documenti da salvare, si riceve un avviso:

UnsavedDocument.png


La cartella di destinazione dei file salvati si può anche definire nella scheda Editore dei parametri dal menu Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.
FileOpenSavePath.png


Altre opzioni si trovano nel menu Modifica → Preferenze → Generale → Documento → Archiviazione

Opzioni

  • Press Esc or the Cancel button to abort the command.

Notes

Preferenze

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Vedere anche: Script di base per FreeCAD

To save a document under a new name use the saveAs method of the document object. For a scripting example see Std New.

Arrow-left.svg Std Save.svg Salva Pagina precedente:
Pagina successiva: Salva una copia Arrow-right.svg