Std SaveAll

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
English • ‎français • ‎italiano • ‎русский

Std SaveAll

Menu location
File → Save All
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
Std Save


Description

The Std SaveAll command saves all open documents.

Usage

  1. Select the File → Save All option from the menu.
  2. For new documents: enter a filename in the dialog box and press the Save button.

Options

  • For new documents: press Esc or the Cancel button to abort the command.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To save a document use the save method of the document object. A new document must first be saved with the saveAs method of the document object. For a scripting example see Std New.