Std Rétablir

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std Redo and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Page précédente : Std Undo.svg Annuler
Page suivante : Couper Std Cut.svg Arrow-right.svg

Std Redo.svg Std Rétablir

Emplacement du menu
Edition → Rétablir
Ateliers
Tous
Raccourci par défaut
Ctrl+Maj+Z
Introduit dans la version
-
Voir aussi
Std Annuler


Description

La commande Std Rétablir inverse l'action de la commande Std Annuler.

Utilisation

  1. Il existe plusieurs façons d'appeler la commande:
    • Appuyez sur le bouton Std Redo.svg Rétablir.
    • Sélectionnez l'option Edition → Std Redo.svg Rétablir dans le menu.
    • Utilisez le raccourci clavier: Ctrl+Y.

Options

  • Pour Rétablir plusieurs actions, cliquez sur la flèche noire vers le bas à droite du bouton Std Redo.svg Std Rétablir et sélectionnez dans la liste.

Préférences

  • La fonctionnalité Annuler/Rétablir peut être désactivée en définissant Outils → Editer paramètres... → BaseApp → Preferences → Document → UsingUndo sur False, mais ce n'est pas recommandé. Ce paramètre peut également être modifié dans l'Editeur de préférences.
  • Le nombre maximum d'étapes Annuler / Rétablir est contrôlé par Outils → Editer paramètres... → BaseApp → Préférences → Document → MaxUndoSize. Ce paramètre peut également être modifié dans l'Editeur de préférences.

Script

Voir aussi: FreeCAD Script de base.

Pour Rétablir une action qui vient d'être annulée, utilisez la méthode redo de l'objet document.

import FreeCAD

FreeCAD.ActiveDocument.redo()
Arrow-left.svg Page précédente : Std Undo.svg Annuler
Page suivante : Couper Std Cut.svg Arrow-right.svg