Std PerspectiveCamera

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std PerspectiveCamera and the translation is 6% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский

Std PerspectiveCamera.svg Std PerspectiveCamera

Ubicación en el Menú
View → Perspective view‏‎
Entornos de trabajo
All
Atajo de teclado por defecto
Introducido en versión
-
Ver también
Orthographic view


Description

Puts the camera in perspective view mode.
Perspective has depth while Orthographic is a fixed depth . You can zoom in and out. You can judge distances. Cameras can be distanced from the scene.

The Std PerspectiveCamera command switches the camera in the active 3D view to perspective view mode. In this mode, objects that are further from the camera appear smaller than those that are closer.

Std PerspectiveCamera example.svg

Two cubes with the same dimensions in perspective view


Usage

  1. There are several ways to invoke the command:
    • Select the View → Std PerspectiveCamera.svg Perspective view option from the menu.
    • Use the keyboard shortcut: V then P.

Notes

  • It is also possible to switch to perspective view mode via the Mini-cube menu of the Navigation Cube.

Preferences

  • The camera type can be changed in the preferences: Edit → Preferences... → Display → 3D View → Camera type. The selected type will be used for all 3D views of all opened documents and also for new documents. See Preferences Editor.

Scripting

See also: FreeCAD Scripting Basics.

To change the view to perspective use the setCameraType method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setCameraType('Perspective')
FreeCADGui.ActiveDocument.ActiveView.getCameraType()