Std Paste

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎čeština • ‎русский

Std Paste.svg Std Paste

Menu location
Edit → Paste
Workbenches
All
Default shortcut
Ctrl+V
Introduced in version
-
See also
Std Cut, Std Copy, Std DuplicateSelection


Description

The Std Paste command pastes objects from the Clipboard into the active document.

Usage

  1. There are several ways to invoke the command:
    • Press the Std Paste.svg Std Paste button.
    • Select the Edit → Std Paste.svg Paste option from the menu.
    • Select the Std Paste.svg Paste option from the Tree view context menu. Note that this option is only available when an exiting object has been selected.
    • Use the keyboard shortcut: Ctrl+V.

Notes

  • FreeCAD will automatically change the internal names and, depending on the preferences, labels of objects to avoid name conflicts.
  • A spreadsheet cell alias that already exists in the spreadsheet will not be pasted.
  • When you are working in a FreeCAD text window, an input box or a spreadsheet, the standard keyboard shortcut Ctrl+V, in almost all cases, does not call the Std Paste command but uses the Paste function from the OS instead.
  • It is not possible to copy-paste native objects between FreeCAD and other applications.

Preferences

  • Duplicate labels are allowed if Tools → Edit parameters... → BaseApp → Preferences → Document → DuplicateLabels is set to True. This setting can also be changed in the Preferences Editor.

Template:Std Base navi/en