Visualizza: Vista ortografica

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std OrthographicCamera and the translation is 44% complete.
Other languages:
English • ‎español • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Std ViewCreate.svg Crea una nuova vista Pagina precedente:
Pagina successiva: Vista in prospettiva Std PerspectiveCamera.svg Arrow-right.svg

Std OrthographicCamera.svg Vista ortografica

Nome nel codice
Std_OrthographicCamera
Posizione nel menu
Visualizza → Vista ortografica
Ambiente
Tutti
Avvio veloce
V O
Introdotto nella versione
-
Vedere anche
Vista in prospettiva


Descrizione

Il comando Std OrthographicCamera commuta la vista 3D attiva nella modalità di visualizzazione ortografica. In questa modalità, gli oggetti più lontani dalla fotocamera non appaiono più piccoli di quelli più vicini.

Std OrthographicCamera example.svg

Two cubes with the same dimensions in orthographic view


Utilizzo

  1. There are several ways to invoke the command:
    • Select the View → Std OrthographicCamera.svg Orthographic view option from the menu.
    • Use the keyboard shortcut: V then O.

Notes

  • It is also possible to switch to orthographic view mode via the Mini-cube menu of the Navigation Cube.

Preferences

  • The camera type can be changed in the preferences: Edit → Preferences... → Display → 3D View → Camera type. The selected type will be used for all 3D views of all opened documents and also for new documents. See Preferences Editor.

Scripting

See also: FreeCAD Scripting Basics.

To change the view to orthographic use the setCameraType method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setCameraType('Orthographic')
FreeCADGui.ActiveDocument.ActiveView.getCameraType()
Arrow-left.svg Std ViewCreate.svg Crea una nuova vista Pagina precedente:
Pagina successiva: Vista in prospettiva Std PerspectiveCamera.svg Arrow-right.svg