Std OrthographicCamera

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std OrthographicCamera and the translation is 6% complete.
Outdated translations are marked like this.
Other languages:
English • ‎español • ‎français • ‎italiano • ‎română • ‎русский

Std OrthographicCamera.svg Std OrthographicCamera

Ubicación en el Menú
View → Orthographic view
Entornos de trabajo
All
Atajo de teclado por defecto
Introducido en versión
-
Ver también
Perspective View


Description

Puts the camera in orthographic view mode.
Orthographic is (according to Wikipedia):
... a means of representing a three-dimensional object in two dimensions...

The Std OrthographicCamera command switches the camera in the active 3D view to orthographic view mode. In this mode, objects that are further from the camera do not appear smaller than those that are closer.

Std OrthographicCamera example.svg

Two cubes with the same dimensions in orthographic view


Usage

  1. There are several ways to invoke the command:
    • Select the View → Std OrthographicCamera.svg Orthographic view option from the menu.
    • Use the keyboard shortcut: V then O.

Notes

  • It is also possible to switch to orthographic view mode via the Mini-cube menu of the Navigation Cube.

Preferences

  • The camera type can be changed in the preferences: Edit → Preferences... → Display → 3D View → Camera type. The selected type will be used for all 3D views of all opened documents and also for new documents. See Preferences Editor.

Scripting

See also: FreeCAD Scripting Basics.

To change the view to orthographic use the setCameraType method of the ActiveView object. This method is not available if FreeCAD is in console mode.

import FreeCADGui

FreeCADGui.ActiveDocument.ActiveView.setCameraType('Orthographic')
FreeCADGui.ActiveDocument.ActiveView.getCameraType()