Команда "Открыть"

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std Open and the translation is 76% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎日本語 • ‎한국어

Std Open.svg Открыть...

Системное название
Std_Open
Расположение в меню
Файл → Открыть...
Верстаки
All
Быстрые клавиши
Ctrl+O
Представлено в версии
-
См. также
Импортировать файл,
Создать файл

Описание

The Std Open command opens a file. If the file is not a native FreeCAD file (*.FCStd) its geometry will be imported into a new document. See Std Import for more information.

Применение

  1. There are several ways to invoke the command:
    • Press the Std Open.svg Std Open button.
    • Select the File → Std Open.svg Open... option from the menu.
    • Use the keyboard shortcut: Ctrl+O.
  2. Optionally select the correct file format in the dialog box.
  3. Select a file.
  4. Press the Open button.

Опции

  • Нажмите Esc или кнопку Отмена, чтобы отменить выполнение команды.

Настройки

  • Путь к последнему файлу к которому была применена данная команда сохраняется в параметр: Инструменты → Редактор параметров... → BaseApp → Preferences → General → FileOpenSavePath.

Программирование

Смотрите так же: Основы составления скриптов в FreeCAD.

To open a document use the open(filepath) method or the openDocument(filepath, [hidden=False]) method of the FreeCAD application.

These methods create and return a document and load a project file into it. The filepath argument must be a string pointing to an existing file. If the file doesn't exist or the file cannot be loaded an I/O exception is thrown. In this case the created document is kept, but will be empty. If hidden=True is used, the document won't be displayed in the GUI and no tab will appear for it. This allows performing automatic operations on a document and closing it without disrupting the user interface.

Примеры составления скрипта смотри в описании команды "Создать".