Std Open

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский • ‎日本語

Std Open.svg Std Open

Menu location
File → Open...
Workbenches
All
Default shortcut
Ctrl+O
Introduced in version
-
See also
Std Import, Std New


Description

The Std Open command opens a file. If the file is not a native FreeCAD file (*.FCStd) its geometry will be imported into a new document. See Std Import for more information.

Usage

  1. There are several ways to invoke the command:
    • Press the Std Open.svg Std Open button.
    • Select the File → Std Open.svg Open... option from the menu.
    • Use the keyboard shortcut: Ctrl+O.
  2. Optionally select the correct file format in the dialog box.
  3. Select a file.
  4. Press the Open button.

Options

  • Press Esc or the Cancel button to abort the command.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To open a document use the open method of the FreeCAD application. For a scripting example see Std New.

Template:Std Base navi/en Template:Userdocnavi/en