Öffnen

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std Open and the translation is 7% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский • ‎日本語

Official icon not found Std Open

Menüeintrag
Datei → Öffnen...
Arbeitsbereich
Alle
Standardtastenkürzel
Strg+O
In der Version eingeführt
-
Siehe auch
Speichern, Importieren...


Öffnet und lädt Projektdateien in den Arbeitsplatz und abhängig von den installierten Erweiterungsmodulen werden weitere Dateitypen unterstützt wie *.IGES, *.STEP, *.BREP, *.STL, *.OBJ, *.PLY, etc.

The Std Open command opens a file. If the file is not a native FreeCAD file (*.FCStd) its geometry will be imported into a new document. See Std Import for more information.

Usage

  1. There are several ways to invoke the command:
    • Press the Std Open.svg Std Open button.
    • Select the File → Std Open.svg Open... option from the menu.
    • Use the keyboard shortcut: Ctrl+O.
  2. Optionally select the correct file format in the dialog box.
  3. Select a file.
  4. Press the Open button.

Options

  • Press Esc or the Cancel button to abort the command.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To open a document use the open method of the FreeCAD application. For a scripting example see Std New.

Template:Std Base navi/de