Std New/ru

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std New and the translation is 75% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский • ‎日本語

Std New.svg Std New

Расположение в меню
Файл → Создать
Верстаки
All
Быстрые клавиши
Ctrl+N
Представлено в версии
-
См. также
Открыть файл,Импортировать файл


Описание

Команда Std New' создаёт новый пустой документ и делает его активным.

Использование

  1. Есть несколько способов вызвать команду:
    • Нажмите кнопку Std New.svg Std New .
    • Выберите в меню опцию Файл → Std New.svg Создать.
    • Используйте клавиатурное сокращение: Ctrl+N.

Настройки

  • FreeCAD создаст новый пустой документ при старте, если Инструменты → Редактор параметров... → BaseApp → Preferences → Document → CreateNewDoc. Это так же может быть изменено в Редакторе настроек.
  • Некоторые свойства документа: имена авторов, название компании и информация о лицензии могут быть предварительно установлены в Редакторе настроек.

Свойства

Most properties can also be changed in the dialog box of the Std ProjectInfo command.

  • DataComment: Any comment that may apply.
  • DataCompany: Company name. Can be preset.
  • DataCreated By: Author name. Can be preset.
  • DataCreation Date: Automatic date stamp. Not editable.
  • DataFile Name: The full path of the file. Blank if the document has not been saved. Not editable.
  • DataId: Not implemented yet.
  • DataLabel: The name that will appear in the Tree view. By default the name of the document.
  • DataLast Modified By: Author name. Can be preset.
  • DataLast Modified Date: Automatic date stamp. Not editable.
  • DataLicense: License type. Can be preset.
  • DataLicense URL: License URL. Can be preset.
  • DataShow Hidden: If true, items that have been hidden in the Tree view will be displayed anyway. Hiding items in the tree can be useful when working on larger models.
  • DataTip: Not implemented yet.
  • DataTip Name: Not implemented yet.
  • DataTransient Dir: The transient directory used for recovery data. Not editable.

Scripting

Смотри так же: Основы скриптов в FreeCAD.

Для создания нового документа используйте метод newDocument приложения FreeCAD.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'test.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)