표준 새 파일(Std New)

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std New and the translation is 94% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎日本語 • ‎한국어

Std New.svg 표준 새 파일

메뉴 위치
파일 → 새 파일
작업대
모두
기본 단축키
Ctrl+N
도입 버전
-
참조
표준 열기, Std Import

설명

표준 새 파일(Std New) 명령은 빈 새 문서를 만들고 활성화 시킵니다.

용법

  1. 이 명령을 실행하는 방법은 여러 가지입니다.
    • Std New.svg 표준 새 파일 버튼을 누릅니다.
    • 메뉴에서 파일 → Std New.svg 새 파일 옵션을 선택합니다.
    • 단축키를 사용합니다: Ctrl+N.

환경 설정

  • Tools → Edit parameters... → BaseApp → Preferences → Document → CreateNewDoctrue로 설정한 경우 FreeCAD를 시작할 때 새 문서가 생성됩니다. 이 설정은 환경설정 편집기에서도 변경할 수 있습니다.
  • 작성자 이름, 회사 이름, 라이센스 정보와 같은 일부 문서 속성은 환경설정 편집기에서 미리 설정할 수 있습니다.

속성

속성은 대부분 표준 프로젝트 정보 명령의 대화 상자에서도 변경할 수 있습니다.

  • 데이터Comment: 적용할 수 있는 모든 설명
  • 데이터Company: 회사 이름. 미리 설정 가능.
  • 데이터Created By: 작성자 이름. 미리 설정 가능.
  • 데이터Creation Date: 자동 날짜 스탬프. 편집 불가능.
  • 데이터File Name: 파일의 전체 경로. 문서 저장 전에는 비어 있음. 편집 불가능.
  • 데이터Id: 미구현.
  • 데이터Label: 트리 보기에 표시될 이름. 기본적으로는 문서 이름.
  • 데이터Last Modified By: 최종 수정자 이름. 미리 설정 가능.
  • 데이터Last Modified Date: 최종 수정일 자동 날짜 스탬프. 편집 불가능.
  • 데이터License: 라이센스 형식. 미리 설정 가능.
  • 데이터License URL: 라이센스 URL. 미리 설정 가능.
  • 데이터Show Hidden: true트리 보기에서 숨긴 항목도 표시됨. 트리에서 항목을 숨기는 기능은 큰 모델 작업을 할 때 유용합니다.
  • 데이터Tip: 미구현.
  • 데이터Tip Name: 미구현.
  • 데이터Transient Dir: 복구 데이터를 위한 임시 디렉토리. 편집 불가능.

스크립트

참조: FreeCAD 스크립트 기초.

새 문서를 만들려면 FreeCAD 애플리케이션의 newDocument 메소드를 사용하십시오.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'test.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)