Std New/新しい

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std New and the translation is 6% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎日本語 • ‎한국어

Std New.svg Std_New

メニューの場所
File -> New
ワークベンチ
All
デフォルトのショートカット
None
バージョンで導入
-
も参照してください
Std_Open,Std_Import

概要

新しい空のドキュメントを作成します。Edit -> Preferences -> General -> Documentタブの該当する設定にチェックをいれることでFreeCADの起動時に自動的に新しい空のドキュメントが作成されるように設定することも可能です。

The Std New command creates a new empty document and makes it the active document.

Usage

  1. There are several ways to invoke the command:
    • Press the Std New.svg Std New button.
    • Select the File → Std New.svg New option from the menu.
    • Use the keyboard shortcut: Ctrl+N.

Preferences

  • FreeCAD will create a new document at start up if Tools → Edit parameters... → BaseApp → Preferences → Document → CreateNewDoc is set to true. This setting can also be changed in the Preferences Editor.
  • Some document properties: author names, company name and license information, can be preset in the Preferences Editor.

Properties

Most properties can also be changed in the dialog box of the Std ProjectInfo command.

  • データComment: Any comment that may apply.
  • データCompany: Company name. Can be preset.
  • データCreated By: Author name. Can be preset.
  • データCreation Date: Automatic date stamp. Not editable.
  • データFile Name: The full path of the file. Blank if the document has not been saved. Not editable.
  • データId: Not implemented yet.
  • データLabel: The name that will appear in the Tree view. By default the name of the document.
  • データLast Modified By: Author name. Can be preset.
  • データLast Modified Date: Automatic date stamp. Not editable.
  • データLicense: License type. Can be preset.
  • データLicense URL: License URL. Can be preset.
  • データShow Hidden: If true, items that have been hidden in the Tree view will be displayed anyway. Hiding items in the tree can be useful when working on larger models.
  • データTip: Not implemented yet.
  • データTip Name: Not implemented yet.
  • データTransient Dir: The transient directory used for recovery data. Not editable.

Scripting

See also: FreeCAD Scripting Basics.

To create a new document use the newDocument([name], [hidden=False]) method of the FreeCAD application. The document name must be unique, which is checked automatically. If no name is supplied, the document will be named "Untitled". If hidden=True is used, the new document won't be displayed in the GUI and no tab will appear for it.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'test.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)