File: Nuovo

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std New and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский • ‎日本語
FreeCAD.png
Pagina successiva: Apri Std Open.svg Arrow-right.svg

Std New.svg Nuovo

Nome nel codice
Std_New
Posizione nel menu
File → Nuovo
Ambiente
Tutti
Avvio veloce
Ctrl+N
Introdotto nella versione
-
Vedere anche
Apri, Importa


Descrizione

Il comando Nuovo crea un nuovo documento vuoto e lo rende il documento attivo.

Utilizzo

  1. Esistono diversi modi per invocare il comando:
    • Premere il pulsante Std New.svg Nuovo.
    • Selezionare l'opzione File → Std New.svg Nuovo dal menu.
    • Usare la scorciatoia da tastiera: Ctrl+N.

Preferenze

  • FreeCAD crea un nuovo documento all'avvio se Strumenti → Modifica parametri... → BaseApp → Preferenze → Documento → CreateNewDoc è impostato su True. Questa impostazione può essere modificata anche nell'editor delle preferenze.
  • Alcune proprietà del documento: nome dell'autore, nome dell'azienda e le informazioni sulla licenza, possono essere preimpostate nell'editor delle preferenze.

Proprietà

Molte proprietà possono anche essere modificate nella finestra di dialogo del comando Informazioni sul progetto.

  • DataComment: Qualsiasi commento applicabile.
  • DataCompany: Nome della ditta. Può essere preimpostato.
  • DataCreated By: Nome dell'autore. Può essere preimpostato.
  • DataCreation Date: Data automatica. Non modificabile.
  • DataFile Name: Il percorso completo del file. Vuoto se il documento non è stato salvato. Non modificabile.
  • DataId: Non ancora implementato.
  • DataLabel: Il nome che apparirà nella vista ad albero. Di default, il nome del documento.
  • DataLast Modified By: Nome dell'autore. Può essere preimpostato.
  • DataLast Modified Date: Data automatica. Non modificabile.
  • DataLicense: Tipo di licenza. Può essere preimpostato.
  • DataLicense URL: URL della licenza. Può essere preimpostato.
  • DataShow Hidden: Se vero, gli elementi che sono stati nascosti nella vista ad albero verranno comunque visualizzati. Nascondere gli oggetti nell'albero può essere utile quando si lavora su modelli molto grandi.
  • DataTip: Non ancora implementato.
  • DataTip Name: Non ancora implementato.
  • DataTransient Dir: La directory temporanea utilizzata per i dati di recupero. Non modificabile.

Script

Vedere anche: Script di base per FreeCAD

Per creare un nuovo documento usa il metodo newDocument dell'applicazione FreeCAD.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'test.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)
FreeCAD.png
Pagina successiva: Apri Std Open.svg Arrow-right.svg