Std Nouveau

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std New and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский • ‎日本語
FreeCAD.png
Page suivante: Std Ouvrir Std Open.svg Arrow-right.svg

Std New.svg Std Nouveau

Emplacement du menu
Fichier → Nouveau
Ateliers
Tous
Raccourci par défaut
Ctrl+N
Introduit dans la version
-
Voir aussi
Std Ouvrir,Std Importer


Description

La commande Std Nouveau crée un nouveau document vide et en fait le document actif.

Utilisation

  1. Lancez la commande de plusieurs manières:
  2. * Sélectionnez l'option File → Std New.svg Nouveau dans le menu.
  3. * Utilisez le raccourci clavier: Ctrl+N.

Préférences

  • FreeCAD créera un nouveau document au démarrage si Outils → Editer paramètres ... → BaseApp → Preferences → Document → CreateNewDoc est réglé sur True. Ce paramètre peut également être modifié dans les Réglage des préférences.
  • Certaines propriétés du document: noms d'auteur, nom de l'entreprise et informations de licence, peuvent être prédéfinies dans Réglage des préférences.

Propriétés

La plupart des propriétés peuvent également être modifiées dans la boîte de dialogue de la commande Std Information sur le projet.

  • DataComment: n'importe quel commentaire.
  • DataCompany: nom de l'entreprise. Peut être prédéfini.
  • DataCreated By: nom de l'auteur. Peut être prédéfini.
  • DataCreation Date: horodatage automatique. Non modifiable.
  • DataFile Name: le chemin complet du fichier. Vide si le document n'a pas été enregistré. Non modifiable.
  • DataId: Pas encore implémenté.
  • DataLabel: nom qui apparaîtra dans la vue en arborescence. Par défaut, le nom du document.
  • DataLast Modified By: nom de l'auteur. Peut être prédéfini.
  • DataLast Modified Date: horodatage automatique. Non modifiable.
  • DataLicense: type de licence. Peut être prédéfini.
  • DataLicense URL: URL de licence. Peut être prédéfini.
  • DataShow Hidden: Si la valeur est true, les éléments qui ont été masqués dans la vue en arborescence seront quand même affichés. Masquer des éléments dans l'arborescence peut être utile lorsque vous travaillez sur des modèles plus grands.
  • DataTip: Pas encore implémenté.
  • DataTip Name: Pas encore implémenté.
  • DataTransient Dir: répertoire transitoire utilisé pour les données de récupération. Non modifiable.

Script

Voir aussi: FreeCAD Script de base.

Pour créer un nouveau document, utilisez la méthode newDocument de l'application FreeCAD.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'test.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)
FreeCAD.png
Page suivante: Std Ouvrir Std Open.svg Arrow-right.svg