Std Neu

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std New and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎日本語 • ‎한국어

Std New.svg Std Neu

Menüeintrag
Datei → Neu
Arbeitsbereich
Alle
Standardtastenkürzel
Strg+N
Eingeführt in Version
-
Siehe auch
Öffnen, Import

Beschreibung

Der Befehl Std Neu erzeugt ein neues leeres Dokument und macht es zum aktiven Dokument.

Anwendung

  1. Es gibt mehrere Wege, um den Befehl aufzurufen:
    • Drücke die Std New.svg Std Neu-Schaltfläche.
    • Wähle die Datei → Std New.svg Neu-Option aus dem Menü.
    • Benutze das Tastaturkürzel: Strg+N.

Einstellungen

  • FreeCAD wird ein neues Dokument beim Start erstellen, falls Werkzeuge → Parameter bearbeiten... → BaseApp → Preferences → Document → CreateNewDoc auf true gesetzt ist. Diese Einstellung kann auch im Voreinstellungseditor geändert werden.
  • Einige Dokumenteigenschaften: Name des Autors, Firmenname und Lizenzinformationen können im Voreinstellungseditor vorgegeben werden.

Eigenschaften

Die meisten Eigenschaften können auch im Dialogfeld des Std ProjektInfo Befehls geändert werden.

  • Daten-EigenschaftKommentar: Jeder Kommentar, der zutreffen könnte.
  • Daten-EigenschaftFirma: Firmenname. Kann voreingestellt werden.
  • Daten-EigenschaftErstellt von: Autorenname. Kann voreingestellt werden.
  • Daten-EigenschaftErstelldatum: Automatischer Datumstempel. Nicht änderbar.
  • Daten-EigenschaftPfad: Der komplette Pfad zur Datei. Leer, falls das Dokument bisher nicht gespeichert wurde. Nicht änderbar.
  • Daten-EigenschaftId: Bisher nicht implementiert.
  • Daten-EigenschaftLabel: Der Name wird in der Baumansicht erscheinen. Standard ist der Name des Dokuments.
  • Daten-EigenschaftZuletzt geändert von: Autorenname. Kann voreingestellt werden.
  • Daten-EigenschaftZuletzt geändert am: Automatischer Datumstempel. Nicht änderbar.
  • Daten-EigenschaftLizenzinformationen: Lizenztyp. Kann voreingestellt werden.
  • Daten-EigenschaftLizenz-URL: Lizenz-URL. Kann voreingestellt werden.
  • Daten-EigenschaftShow Hidden: Falls aktiviert, werden in der Baumansicht verborgene Elemente trotzdem angezeigt. Verborgene Elemente im Baum können bei der Arbeit an größeren Modellen nützlich sein.
  • Daten-EigenschaftTip: Bisher nicht implementiert.
  • Daten-EigenschaftTip Name: Bisher nicht implementiert.
  • Daten-EigenschaftTransient Dir: Das flüchtige Verzeichnis wird für Sicherheitskopien benutzt. Nicht änderbar.

Skripten

Siehe auch: FreeCAD Grundlagen Skripten.

Um ein neues Dokument zu erstellen, verwende die newDocument([name], [hidden=False])-Methode der FreeCAD-Anwendung. Der Dokumentname muss eindeutig sein, was automatisch geprüft wird. Falls kein Name eingeben wird, bekommt das Dokument den Namen "Untitled". Falls hidden=True benutzt wird, wird das neue Dokument nicht in der GUI angezeigt und es wird kein Reiter dafür erscheinen.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'test.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)