Std Graphique de dépendance

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std ExportGraphviz and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Page précédente: Inspecteur de scène‏‎
Page suivante: Utilitaire de projet Arrow-right.svg

Std Graphique de dépendances

Emplacement du menu
Outils → Graphique de dépendance...
Ateliers
Tous
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Aucun


Description

La commande Std Graphique de dépendances 'affiche les dépendances entre les objets du document actif dans un' graphique de dépendance '. Contrairement à la vue en arborescence, les objets sont répertoriés dans l'ordre chronologique inverse, avec le premier objet créé en bas.

Il peut être utile pour analyser un document FreeCAD et localiser des fourches dans l'arborescence. La forme du graphe dépendra de l'atelier utilisé pour créer les objets du document. Par exemple, un modèle créé exclusivement dans l'atelier PartDesign peut afficher un graphique de dépendances linéaire avec une seule branche verticale. Un modèle fait sous l'atelier Part sera formé de plusieurs branches, mais pour une pièce unique, celles-ci se joindront au sommet après des opérations Booléennes. Si ce n,est pas le cas, alors il s'agit d'objets distincts.

Le graphique de dépendance est purement un outil de visualisation, il ne peut donc pas être édité. Il se met automatiquement à jour si des changements sont apportés au modèle.

Std ExportGraphviz example.svg

Exemple de graphe de dépendances avec un corps PartDesign à gauche et un objet créé avec des opérations Part à droite


Installation

Pour utiliser la commande, un logiciel tiers nommé Graphviz doit être installé. Si vous ne l'avez pas préinstallé ou s'il est installé dans un emplacement non conventionnel, FreeCAD affichera la boîte de dialogue suivante:

FreeCAD-0.17-missing-Graphviz-error-dialogue.png

Windows

Téléchargez l'installateur graphviz-2.xx.msi depuis la page de téléchargement puis lancez l'installation.

MacOSX

Vous pouvez installer graphviz à l'aide du gestionnaire de paquets Homebrew :

brew install graphviz

Cela installe les fichiers binaires de graphviz dans /usr/local/bin. Malheureusement, il n'est pas possible d'y naviguer depuis la boîte de dialogue qui s'ouvre lorsque le menu Outils → Graphique de dépendance.... Quand cette boîte de dialogue s'ouvre, utilisez les touches Cmd+Maj+G pour obtenir un champ de saisie pour le chemin. Saisissez

/usr/local/bin

puis confirmez le champ de saisie et l'invite de dialogue.

Au cas où les fichiers Graphviz seraient installés à un autre emplacement, tentez de trouver le programme avec la commande

type dot

Le résultat ressemblera à

dot is /usr/local/bin/dot

Et vous pouvez ensuite diriger FreeCAD vers ce répertoire.

Linux

Dans la plupart des distributions Linux (Debian/Ubuntu, Fedora, OpenSUSE), il suffit d'installer le paquet graphviz depuis les dépôts. Toutefois, similaire à Mac/OSX, dans certains cas les fichiers binaires de Graphviz sont installés dans un emplacement non-standard. Essayez de trouver le programme avec la commande:

type dot

Le résultat pourrait être

dot is /usr/local/bin/dot

Et vous pouvez ensuite diriger FreeCAD vers ce répertoire.

Utilisation

  1. Sélectionnez l'option Outils → Graphique de dépendance... dans le menu.
  2. Un nouvel onglet intitulé Graphique de dépendance s'ouvre dans Zone de vue principale.
  3. Utilisez la molette de défilement de la souris pour effectuer un zoom avant ou arrière.
  4. Utilisez les curseurs en bas et à droite de l'écran pour effectuer un panoramique de la vue.

Enregistrer

Vous pouvez enregistrer un graphique de dépendance:

  1. Assurez-vous que l'onglet Graphique des dépendances est au premier plan.
  2. Sélectionnez l'option Fichier → Enregistrer ou Fichier → Enregistrer sous dans le menu.
  3. Saisissez un nom de fichier et sélectionnez le type de fichier (*.png, *.bmp, *.gif, *.jpg, *.svg ou *.pdf).
  4. Appuyez sur le bouton Enregistrer.

Principes généraux

  • Le graphe affiche les objets en ordre chronologique inversé, de bas en haut.
  • La direction des flèches indiquant les dépendances doit toujours pointer vers le bas, de l'objet enfant à l'objet parent. Une flèche pointant vers le haut indique une dépendance cyclique, un problème qui doit être résolu.
  • Une esquisse contenant des liens vers des géométries externes aura un numéro avec un suffixe "x" à côté de la flèche la reliant à son parent, indiquant le nombre de géométries externes liées dans l'esquisse.
  • Les objets peuvent avoir des dépendances à plusieurs parents. Par exemple, pour un modèle construit dans Atelier PartDesign, une cavité (Pocket) sera liée à son esquisse (Sketch) et à la fonctionnalité Protrusion (Pad) qui l’a précédée.
  • Les dépendances non autorisées (par exemple, entre une opération Atelier Draft/Atelier Part et un élément à l'intérieur d'un PartDesign Corps) seront affichées avec une flèche rouge. Ce type de lien affiche généralement une erreur 'Links go out of allowed scope' (Liens hors de portée autorisée) dans la Vue rapport.
  • Le conteneur Part et le Corps PartDesign englobent leur contenu dans un encadré avec un arrière-plan de couleur aléatoire. Leur origine englobe également leur contenu (plans et axes standard) dans un encadré.
  • Le Groupe est affiché comme un élément unique lié à son contenu.

Limitations

  • Le graphique de dépendance ne peut pas détecter les problèmes causés par le Problème de dénomination topologique. Si une esquisse change de face après une modification, elle est toujours liée à la fonction. Même si certaines fonctions sont rompues, le graphique de dépendance restera inchangé.
Arrow-left.svg Page précédente: Inspecteur de scène‏‎
Page suivante: Utilitaire de projet Arrow-right.svg