Std Export

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Std Export

Menu location
File → Export...
Workbenches
All
Default shortcut
Ctrl+E
Introduced in version
-
See also
Std PrintPdf, Import Export, Import Export Preferences


Description

The Std Export command exports selected objects to a different file format. Many file formats are supported and for some formats multiple export options exist. See Import Export for more information.

Usage

  1. Select one or more objects. To avoid exporting invisible or duplicate objects:
    • Be careful when you use Ctrl+A to select all objects. This will also select invisible objects.
    • Select a PartDesign Body by only picking the body itself or its last feature.
    • Select a Std Group or a Std Part by only picking the parent object itself or the objects nested inside it.
    • Do not use the Std SelectAll command as it will also select sub-elements of PartDesign Bodies.
    • For the same reason the Std BoxSelection command should be avoided in FreeCAD version 0.18 and earlier.
  2. There are several ways to invoke the command:
    • Select the File → Export... option from the menu.
    • Use the keyboard shortcut: Ctrl+E.
  3. Select the correct file format in the dialog box.
  4. Enter a filename.
  5. Press the Save button.

Options

  • Press Esc or the Cancel button to abort the command.

Notes

Preferences

  • See: Import Export Preferences.
  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.
  • The last used export filter is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileExportFilter.