Std DuplicateSelection/ru

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std DuplicateSelection and the translation is 0% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎čeština • ‎русский • ‎한국어
Arrow-left.svg Previous: Std Paste.svg Paste
Next: Refresh Std Refresh.svg Arrow-right.svg

Std DuplicateSelection.svg Std DuplicateSelection

Расположение в меню
Правка → Дублировать выбранное
Верстаки
Все
Быстрые клавиши
Никто
Представлено в версии
-
См. также
Std Cut, Копировать, Вставить

Description

The Std DuplicateSelection command duplicates objects within the active document.

Usage

  1. Select one or more objects.
  2. Select the Edit → Duplicate selected object option from the menu.
  3. If the objects have dependencies that have not been selected, a dialog box will prompt you to specify which should be included.

Notes

  • FreeCAD will automatically change the internal names and, depending on the preferences, labels of objects to avoid name conflicts.

Preferences

  • Duplicate labels are allowed if Tools → Edit parameters... → BaseApp → Preferences → Document → DuplicateLabels is set to true. This setting can also be changed in the Preferences Editor.

Scripting

The Std DuplicateSelection command can be applied after selecting one or more objects in the Tree view:

FreeCADGui.runCommand('Std_DuplicateSelection')

The selection can be manual (by using the mouse), or via the Python console.
To know more about selecting objects programmatically, refer to Selection methods.


Arrow-left.svg Previous: Std Paste.svg Paste
Next: Refresh Std Refresh.svg Arrow-right.svg