Std Dupliquer une sélection

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std DuplicateSelection and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎čeština • ‎русский • ‎한국어
Arrow-left.svg Page précédente : Std Paste.svg Coller
Page suivante : Rafraîchir Std Refresh.svg Arrow-right.svg

Std DuplicateSelection.svg Std Dupliquer la Sélection

Emplacement du menu
Edition → Dupliquer la sélection
Ateliers
tous
Raccourci par défaut
Aucun
Introduit dans la version
-
Voir aussi
Std Copier, Std Coller

Description

La commande Std Dupliquer la sélection duplique les objets dans le document actif.

Utilisation

  1. Sélectionnez un ou plusieurs objets.
  2. Sélectionnez l'option Edition → Dupliquer la sélection dans le menu.
  3. Si les objets ont des dépendances qui n'ont pas été sélectionnées, une boîte de dialogue vous demandera de spécifier ceux qui doivent être inclus.

Remarques

  • FreeCAD changera automatiquement les noms internes et, selon les préférences, les étiquettes des objets pour éviter les conflits de noms.

Préférences

  • Les étiquettes en double sont autorisées si Outils → Editer les paramètres... → BaseApp → Preferences → Document → DuplicateLabels est défini sur true. Ce paramètre peut également être modifié dans l'Editeur de préférences.

Script

La commande Std Dupliquer la sélection peut être appliquée après avoir sélectionné un ou plusieurs objets dans la Vue en arborescence:

FreeCADGui.runCommand('Std_DuplicateSelection')

La sélection peut être manuelle (en utilisant la souris) ou via la Console Python.
Pour en savoir plus sur la sélection d'objets de manière programmatique, reportez-vous à Méthodes de sélection.


Arrow-left.svg Page précédente : Std Paste.svg Coller
Page suivante : Rafraîchir Std Refresh.svg Arrow-right.svg