Edytor parametrów

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std DlgParameter and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Std DlgParameter.svg Edytor parametrów

Lokalizacja w menu
Narzędzia → Edytor parametrów ...
Środowisko pracy
Wszystkie
Domyślny skrót
brak
Wprowadzono w wersji
-
Zobacz także
Edytor preferencji

Opis

Polecenie Std DlgParameter otwiera Edytor Parametrów. W Edytorze parametrów można sprawdzać parametry sterujące zachowaniem programu FreeCAD i jego stanowisk pracy oraz opcjonalnie je usunąć, dodać lub zmienić. Parametry są przechowywane w pliku o nazwie user.cfg, lokalizacja tego pliku zależy od systemu operacyjnego.

Praca z edytorem parametrów wymaga pewnego doświadczenia. Dla najpopularniejszych parametrów można również skorzystać z wygodniejszego Edytora preferencji.

Std DlgParameter dialog.png

Okno dialogowe Edytor parametrów

Użycie

Przejdź do menu Tools → Std DlgParameter.svg Edycja parametrów.

  1. Otwiera się okno dialogowe Edytor parametrów. Więcej informacji można znaleźć w sekcji Opcje.
  2. Opcjonalnie wciśnij przycisk Zapisz na dysku, aby natychmiast zaktualizować plik user.cfg. Nie jest to wymagane, ponieważ FreeCAD automatycznie zaktualizuje ten plik po zamknięciu aplikacji.
  3. Naciśnij przycisk Zamknij, aby zamknąć Edytor Parametrów.

Opcje

Panel lewy

W lewym panelu wyświetlane jest drzewo z grupami parametrów oraz podgrupami.

"W menu kontekstowym panelu dostępne są następujące opcje:"

Rozwiń / Zwiń

  1. Jeśli wybrana grupa posiada jedną lub więcej podgrup, można ją rozszerzyć lub zwinąć wybierając tę opcję z menu kontekstowego. Ale możesz również rozwinąć i zwinąć drzewo w zwykły sposób.

Dodaj grupę podrzędną

  1. Wybierz grupę.
  2. Wybierz opcję Dodaj podgrupęz menu kontekstowego.
  3. Wprowadź nazwę nowej grupy podrzędnej w otwartym oknie dialogowym.
  4. Wciśnij przycisk OK.

Usuń grupę

  1. Wybierz grupę.
  2. Wybierz z menu kontekstowego opcję Usuń grupę.
  3. W otwartym oknie dialogowym naciśnij przycisk Tak, aby potwierdzić, że chcesz usunąć tą grupę (łącznie ze wszystkimi jej podgrupami, oraz wszystkimi parametrami w grupie i jej podgrupach).

Zmień nazwę grupy

  1. Wybierz grupę.
  2. Wybierz opcję Zmień nazwę grupy z menu kontekstowego.
  3. Wprowadź nową nazwę.
  4. Nazwę grupy można też zmienić klikając w nią dwukrotnie.

Eksportuj parametr

  1. Wybierz grupę.
  2. Wybierz opcję Eksportuj parametr z menu kontekstowego.
  3. Wprowadź nazwę pliku w oknie dialogowym.
  4. Wciśnij przycisk Zapisz.

Importuj parametr

  1. Wybierz grupę, która nie zawiera żadnych podgrup lub usuń je w pierwszej kolejności. Wszystkie istniejące parametry w grupie zostaną usunięte.
  2. Wybierz opcję Importuj parametr z menu kontekstowego.
  3. Wybierz plik typu *.FCParam w oknie dialogowym.
  4. Wciśnij przycisk Otwórz.

Panel prawy

Prawy panel pokazuje parametry wybranej grupy w lewym panelu. Jeśli ta grupa zawiera tylko podgrupy, prawy panel będzie pusty.

"W menu kontekstowym panelu dostępne są następujące opcje:"

Zmień wartość

  1. Wybierz parametr.
  2. Wybierz z menu kontekstowego opcję Zmień wartość.
  3. Wprowadź nową wartość w otwartym oknie dialogowym.
  4. Naciśnij przycisk OK.
  5. Wartość parametru można również zmienić, klikając dwukrotnie jego pole o nazwie Typ lub Wartość.

Usuń element z wartością

  1. Wybierz parametr.
  2. Wybierz z menu kontekstowego opcję Usuń element z wartością.

Zmień nazwę wartości

  1. Wybierz parametr.
  2. Wybierz z menu kontekstowego opcję Zmień nazwę wartości.
  3. Wprowadź nową nazwę.
  4. Nazwę parametru można również zmienić klikając dwukrotnie na jego pole "Nazwa".

Nowy element tekstowy

  1. Wybierz z menu kontekstowego opcję Nowy element tekstowy lub Nowy → Nowy element tekstowy.
  2. Wprowadź nazwę w otwartym oknie dialogowym.
  3. Naciśnij przycisk OK.
  4. Wprowadź wartość w następnym oknie dialogowym.
  5. Naciśnij przycisk OK.

Nowy element z liczbą zmiennoprzecinkową

  1. Wybierz z menu kontekstowego opcję Nowy element z liczbą zmiennoprzecinkową lub Nowy → Nowy element z liczbą zmiennoprzecinkową.
  2. Kolejne kroki są podobne do tych dla Nowy element tekstowy

Nowy element z liczbą całkowitą

  1. Wybierz z menu kontekstowego opcję Nowy element z liczbą całkowitą lub Nowy → Nowy element z liczbą całkowitą.
  2. Kolejne kroki są podobne do tych dla Nowy element tekstowy

Nowy element bez typu

  1. Wybierz z menu kontekstowego opcję Nowy element bez typu lub Nowy → Nowy element bez typu.
  2. Kolejne kroki są podobne do tych dla Nowy element tekstowy

Nowy element z wartością logiczną

  1. Wybierz z menu kontekstowego opcję Nowy element z wartością logiczną lub Nowy → Nowy element z wartością logiczną.
  2. Kolejne kroki są podobne do tych dla Nowy element tekstowy

Sortowanie

Domyślnie, grupy lewego panelu na każdym poziomie drzewa są sortowane alfabetycznie, a parametry w prawym panelu również sortowane są alfabetycznie. Kolejność wyświetlania w każdym panelu można odwrócić, klikając odpowiednio nagłówek Grupa lub Nazwa.

Szybkie wyszukiwanie

Wpisanie ciągu znaków (nawet kilku znaków) w tym polu wprowadzania danych, spowoduje pełne rozwinięcie drzewa lewego panela i podświetlenie wszystkich grup o nazwach odpowiadających wprowadzonej wartości. Jeśli nie zostaną znalezione żadne dopasowania, tło pola wejściowego zmieni kolor na czerwony.

Znajdź

  1. W lewym panelu wybierz grupę, w której chcesz rozpocząć wyszukiwanie. Kierunek wyszukiwania będzie przebiegał w dół. Wyszukiwanie nie jest ograniczone do grupy i jej podgrup, ale raczej do wybranej grupy i wszystkiego, co znajduje się pod nią w drzewie.
  2. Naciśnij przycisk Znajdź...
  3. Wprowadź ciąg znaków w polu wprowadzania Znajdź to. W wyszukiwaniu nie uwzględnia się wielkości liter.
  4. Zaznacz jedno lub więcej pól wyboru CheckBoxTrue.svg Grupy, CheckBoxTrue.svg Nazwy i CheckBoxTrue.svg Wartości. Należy pamiętać, że przeszukiwane będą tylko wartości ciągów znaków.
  5. Opcjonalnie (odznacz)zaznacz pole wyboru CheckBoxTrue.svg Dopasuj tylko cały ciąg.
  6. Naciśnij przycisk Znajdź następny, aby odnaleźć pierwszą grupę z dopasowaniem. Pasujące parametry nie są wyróżniane indywidualnie. Opcjonalnie można tąc zynność powtarzać aż do momentu, gdy nie będzie można znaleźć kolejnych dopasowań.
  7. Możliwe jest rozpoczęcie nowego wyszukiwania bez zamykania okna dialogowego. Ponowne wybranie grupy, od której należy rozpocząć wyszukiwanie, jest wtedy zazwyczaj wymagane.
  8. Użyj przycisku Anuluj, aby zamknąć okno dialogowe.

Uwagi

Tworzenie skryptów

Zobacz również: FreeCAD podstawy tworzenia skryptów.

Dostęp do preferencji można uzyskać ze skryptów środowiska Python, używając odpowiedniej ścieżki w Edytorze parametrów. Na przykład, preferencja Edycja → Preferencje → Import-Eksport → DXF → Opcje importu → Łącz geometrie pojawia się w Narzędzia → Edycja parametrów → BaseApp → Preferences → Mod → Draft → dxfCreatePart i ma typ Boolean. Można więc uzyskać do niej dostęp w środowisku Python za pomocą następującego kodu:

# get:
App.ParamGet("User parameter:BaseApp/Preferences/Mod/Draft").GetBool('dxfCreatePart')
# set:
App.ParamGet("User parameter:BaseApp/Preferences/Mod/Draft").SetBool('dxfCreatePart', True)

Znalezienie, który parametr jest używany do przechowywania jakiej opcji z edytora Preferencji może wymagać nieco poszukiwań, ale Edytor parametrów oferuje możliwość przeszukiwania, co powinno być pomocne.

Modyfikowanie preferencji innych części programu FreeCAD jest raczej złym pomysłem, chyba że robi się to na życzenie użytkownika. Jednakże ustawianie parametrów może być użyte do określenia parametrów dla własnego środowiska pracy, a pobieranie może być użyte do przestrzegania istniejących parametrów.