Strumenti: Grafico delle dipendenze

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std DependencyGraph and the translation is 94% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский
Arrow-left.svg Ispettore di scena Pagina precedente:
Pagina successiva: Utilità di progetto Arrow-right.svg

Grafico delle dipendenze

Nome nel codice
Std_DependencyGraph
Posizione nel menu
Strumenti → Grafico delle dipendenze...
Ambiente
Tutti
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Nessuno


Descrizione

Il Grafico delle dipendenze mostra sotto forma di grafico le dipendenze tra gli oggetti presenti nel documento attivo. A differenza della Vista ad albero, gli oggetti sono elencati in ordine cronologico inverso, con il primo oggetto creato situato nella parte inferiore.

Può essere utile per analizzare un documento di FreeCAD e localizzare le biforcazioni nell'albero della struttura. L'aspetto grafico delle dipendenze dipende da quale ambiente di lavoro è stato utilizzato per creare gli oggetti presenti nel documento. Ad esempio, un modello realizzato esclusivamente nell'ambiente PartDesign dovrebbe visualizzare un grafico delle dipendenze lineare con un singolo ramo verticale. Un modello realizzato con operazioni Parte ha molti rami, ma per avere una sola parte questi rami devono confluire in un unico elemento collocato in cima dopo le operazioni booleane. Se non lo fanno, vuol dire che ci sono degli oggetti separati.

Il grafico delle dipendenze è uno strumento di pura visualizzazione, quindi non può essere modificato, Si aggiorna automaticamente se vengono apportate delle modifiche al modello.

Std DependencyGraph example.svg

Esempio di grafico delle dipendenze con un corpo di PartDesign a sinistra e un oggetto creato con le operazioni di Parte a destra


Installazione

Per utilizzare il grafico delle dipendenze, si deve prima installare un software di terze parti chiamato Graphviz. Se Graphviz non è installato in precedenza o è installato in una posizione non convenzionale, FreeCAD visualizza il seguente dialogo:

FreeCAD-0.17-missing-Graphviz-error-dialogue.png

Windows

Scaricare l'installatore graphviz-2.xx.msi dalla pagina Graphviz Download e lanciarlo per eseguire l'installazione.

Mac/OSX

È possibile installare graphviz usando Homebrew:

brew install graphviz

Questo installa i binari graphviz in /usr/local/bin. Purtroppo non è possibile esplorare quella posizione direttamente dalla finestra di dialogo sui file che si apre con Strumenti → Grafico delle dipendenze....

Quando si ottiene la finestra di selezione dei file utilizzare i tasti Cmd+Shift+G per ottenere un campo di input per il percorso. Inserire

/usr/local/bin

poi confermare il campo di immissione e la finestra di dialogo di selezione dei file.

Nel caso in cui i binari di Graphviz non siano installati nella posizione standard, cercare di trovare il programma con il comando

type dot

Uscirà qualcosa di simile

dot is /usr/local/bin/dot

Quindi si può dire a FreeCAD di cercare in quella directory.

Linux

Sulla maggior parte delle distribuzioni Linux (Debian/Ubuntu, Fedora, OpenSUSE), è sufficiente installare il pacchetto graphviz dai repository. Nel caso in cui i binari di Graphviz non siano installati nella posizione standard, cercare di trovare il programma con il comando:

type dot

Può produrre qualcosa di simile

dot is /usr/local/bin/dot

Quindi si può dire a FreeCAD di cercare in quella directory.

Utilizzo

  1. Andare nel menu Strumenti → Grafico delle dipendenze....
  2. Nella vista principale si apre una nuova finestra dal titolo Grafico delle dipendenze.
  3. Utilizzare la rotellina del mouse per ingrandire o rimpicciolire il grafico.
  4. Utilizzare il dispositivo di scorrimento orizzontale nella parte inferiore dello schermo per scorrere la vista lateralmente.

Salva

È possibile salvare un grafico delle dipendenze:

  1. Assicurarsi che la scheda del grafico delle dipendenze sia in primo piano.
  2. Selezionare l'opzione File → Salva o File → Salva con nome dal menu.
  3. Immettere un nome per il file e selezionare il tipo di file (*.png, *.bmp, *.gif, *.jpg, *.svg or *.pdf).
  4. Premere il pulsante Salva.

Principi generali

  • Il grafico mostra gli oggetti in ordine cronologico inverso, dal basso verso l'alto.
  • La direzione delle frecce che mostrano le dipendenze dovrebbe sempre puntare verso il basso, dall'oggetto figlio all'oggetto genitore. Una freccia rivolta verso l'alto indica una dipendenza ciclica, ed è un problema che deve essere risolto.
  • Uno schizzo che contiene collegamenti a una geometria esterna, oltre alla freccia che lo collega al suo genitore, ha un numero con un suffisso 'x' e mostra il numero della geometria esterna collegata nello schizzo.
  • Gli oggetti possono avere dipendenze da più genitori. Ad esempio, per un modello costruito in PartDesign, una Tasca può essere collegata al suo Schizzo e alla funzione Pad che lo precede.
  • Le dipendenze non consentite (ad esempio tra un'operazione di Draft o Part e un elemento all'interno di un Corpo di PartDesign) sono visualizzate con una freccia rossa. Questo tipo di collegamento mostra in genere un errore 'Links go out of allowed scope' nella vista reportvista report.
  • Un Contenitore Part e un Corpo PartDesign racchiudono il loro contenuto all'interno di una cornice con uno sfondo colorato a caso. Anche la loro origine racchiude il suo contenuto (piani e assi standard) in una cornice.
  • Un Gruppo viene visualizzato come un singolo elemento collegato al suo contenuto.

Limitazioni

  • Il grafico delle dipendenze non è di aiuto con problemi causati dal problema della denominazione topologica. Se uno schizzo scambia le facce di una funzione dopo una modifica, esso è ancora collegato alla funzione. Anche se alcune funzioni sono interrotte, il grafico delle dipendenze rimane invariato.
Arrow-left.svg Ispettore di scena Pagina precedente:
Pagina successiva: Utilità di progetto Arrow-right.svg