Std AbhängigkeitsGraph

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Std DependencyGraph and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Official icon not found {{{Name/de}}}

Menüeintrag
Werkzeuge → AbhängigkeitsGraph...
Arbeitsbereich
Alle
Standardtastenkürzel
None
In der Version eingeführt
-
Siehe auch
None


Beschreibung

Der Std AbhängigkeitsGraph Befehl zeigt die Abhängigkeiten zwischen Objekten im aktiven Dokument in einem 'Abhängigkeitsgraphen' an. Im Gegensatz zur Baumansicht werden die Objekte in umgekehrter chronologischer Reihenfolge aufgelistet, wobei das erste erstellte Objekt unten steht.

Es kann bei der Analyse eines FreeCAD Dokuments und beim Auffinden von Verzweigungen in einem Baum nützlich sein. Das Layout des Abhängigkeitsgraphen hängt davon ab, welcher Arbeitsbereich verwendet wurde, um die Objekte im Dokument zu erstellen. Beispielsweise kann ein Modell, das ausschließlich im Arbeitsbereich PartDesign erstellt wurde, einen linearen Abhängigkeitsgraphen mit einem einzigen vertikalen Zweig anzeigen. Ein Modell, das mit Part Vorgängen erstellt wurde, hat viele Zweige, aber für ein einzelnes Teil schließen sie sich nach Booleschen Vorgängen oben an. Wenn dies nicht der Fall ist, bedeutet dies, dass sie separate Objekte sind.

Der Abhängigkeitsgraph ist ein reines Visualisierungswerkzeug, daher kann er nicht bearbeitet werden. Er wird automatisch aktualisiert, wenn Änderungen am Modell vorgenommen werden.

Std DependencyGraph example.svg

Beispiel eines Abhängigkeitsdiagramms mit einem PartDesign Körper auf der linken Seite und einem mit Teiloperationen erzeugten Objekt auf der rechten Seite


Installation

Um den Befehl verwenden zu können, muss eine Drittanbieter-Software namens Graphviz installiert sein. Wenn du diese nicht vorinstalliert hast oder sie an einem unkonventionellen Ort installiert ist, zeigt FreeCAD den folgenden Dialog an:

FreeCAD-0.17-missing-Graphviz-error-dialogue.png

Windows

Lade das graphviz-2.xx.msi Installationsprogramm von der Graphviz Downloadseite herunter und starte es, um es zu installieren.

Mac/OSX

Du kannst graphviz mit Homebrew installieren. (Werde bei der Installation von Homebrew nicht nervös, wenn MacOS dich auffordert, Updates zu installieren, z.B. für die Xcode Kommandozeilenprogramme. Diese Updates werden später durch den Installationsprozess durchgeführt).

brew install graphviz

Dadurch werden die Graphviz Binärdateien unter /usr/local/bin installiert. FreeCAD wird dort ganz von selbst suchen. Wenn das Programm dort nicht gefunden wird, wirst du aufgefordert, den Pfad einzugeben. Leider können wir vom Dateidialog aus, der aus Werkzeuge → Abhängigkeitsgraph... aufgerufen wird, nicht direkt dorthin navigieren. Wenn du den Dateiauswahldialog erhälst, hast du zwei Möglichkeiten: Du kannst die Tastenkombination Cmd+Shift+. verwenden, die dir alle ausgeblendeten Elemente anzeigt. Oder du verwendest die Tastenkombination Cmd+Shift+G, um ein Eingabefeld für den Pfad zu erhalten. Eingabe von

/usr/local/bin

und bestätige das Eingabefeld und den Dateiauswahldialog.

Falls die Graphviz Binärdateien an einem nicht-standardmäßigen Ort installiert sind, versuche, das Programm mit dem Befehl zu finden

type dot

Sie wird etwas ausgeben wie

dot is /usr/local/bin/dot

Und deshalb kannst du FreeCAD anweisen, in diesem Verzeichnis zu suchen.

Linux

Auf den meisten Linux Distributionen (Debian/Ubuntu, Fedora, OpenSUSE) musst du nur das Paket graphviz aus den Repositorien installieren. Ähnlich wie bei Mac/OSX versuche jedoch, in Fällen, in denen die Graphviz Binärdateien an einem nicht standardmäßigen Ort installiert sind, das Programm mit dem Befehl zu finden:

type dot

Sie wird etwas ausgeben wie

dot is /usr/local/bin/dot

Und deshalb kannst du FreeCAD darauf hinweisen, in diesem Verzeichnis zu suchen.

Anwendung

  1. Wähle die Option Werkzeuge → Abhängigkeitsdiagramm... aus dem Menü.
  2. Ein neuer Reiter mit dem Titel Abhängigkeitsdiagramm wird im Hauptansichtsbereich geöffnet.
  3. Verwende zum Vergrößern oder Verkleinern das Scrollrad der Maus.
  4. Verwende die Schieberegler unten und rechts auf dem Bildschirm, um die Ansicht zu verschieben.

Speichern

Du kannst ein Abhängigkeitsdiagramm speichern:

  1. Stelle sicher, dass das Register Abhängigkeitsdiagramm im Vordergrund ist.
  2. Wähle die Option Datei → Speichern oder Datei → Speichern als aus dem Menü.
  3. Gib einen Dateinamen ein und wähle den Dateityp (*.png, *.bmp, *.gif, *.jpg, *.svg oder *.pdf).
  4. Drücke die Taste Save.

Allgemeine Grundsätze

  • Die Grafik zeigt die Objekte in umgekehrter chronologischer Reihenfolge.
  • Die Richtung der Pfeile, die Abhängigkeiten anzeigen, sollte immer nach unten zeigen, vom untergeordneten Objekt zum übergeordneten Objekt. Ein Pfeil, der nach oben zeigt, weist auf eine zyklische Abhängigkeit hin, ein Problem, das gelöst werden muss.
  • Eine Skizze, die Verknüpfungen zu externe|externe Geometrie enthält, hat neben dem Pfeil, der sie mit dem übergeordneten Objekt verknüpft, eine Nummer mit dem Suffix 'x', die die Anzahl der in der Skizze verknüpften externen Geometrien anzeigt.
  • Objekte können Abhängigkeiten zu mehreren übergeordneten Objekten haben. Beispielsweise kann bei einem Modell, das in PartDesign erstellt wurde, eine Tasche mit ihrer Skizze und mit dem Polster Formelement verknüpft sein, das ihr vorausging.
  • Unzulässige Abhängigkeiten (z.B. zwischen einem Entwurf/Part Vorgang und einem Element innerhalb eines PartDesign Körper) werden mit einem roten Pfeil angezeigt. Diese Art von Link zeigt normalerweise einen Fehler 'Verknüpfungen gehen außerhalb des zulässigen Bereichs' in der Berichtsansicht an.
  • Ein Part Container und PartDesign Körper umschließen ihren Inhalt innerhalb eines Rahmens mit einem zufällig gefärbten Hintergrund. Ihr Ursprung umschließt ebenfalls seinen Inhalt (Standardebenen und -achsen) in einem Rahmen.
  • Ein Gruppen wird als ein einzelnes Element angezeigt, das mit seinem Inhalt verknüpft ist.

Begrenzungen

  • Der Abhängigkeitsgraph kann beim topologischen Benennungsproblem nicht helfen. Wenn eine Skizze nach einer Bearbeitung die Flächen eines Formelements wechselt, ist sie immer noch mit dem Formelement verknüpft. Selbst wenn einige Formelemente gebrochen sind, bleibt der Abhängigkeitsdiagramm unverändert.

Template:Std Base navi/de